WSJT-X "error in sound input"

Greetings from the field (using cell phone enabled hotspot for this)
I’ve been a happy DigiRig owner for some time now, many successful excursions with it and my FT-891. Out in the field playing radio for a 3-day weekend, tho, and getting error box in WSJT-X (and JS8CALL) “Error in Sound Input” An error opening the audio input device has occurred." Hmmmm. Checked and re-seated all cables. Sound levels look good. Any thoughts? Looks like Digital Modes are going to be a zero this weekend. :frowning:

Tim M. , KD9LAI

This could be an RFI issue. Does this happen before you attempt transmitting?

K0TX, thanks for your response. I think you may be right. Thankfully I had my LDG 1:1 with me. I hadn’t had this issue before, but usually carry the LDG with me into the field. I’m going to keep experimenting. Right now I’m on 40m, with the 1:1 inline and it’s working so far. Thanks again!

I just purchased a DigiRig for my Elecraft KX2. I get the same error when transmitting on FT8. I did some searching and reading on the web and it looks like it is RFI. I put a over the wire ferrite clamp next to the DigiRig box. I could transmit at 1 watt. Anything higher gets me the same audio error. The Ferrite clamp went over the sound cables. How do I get up to 5 watts? Do I need shorter cables? Add more ferrite/toroids? Does any of the RFI come in through the serial cable? Should that be protected as well?? Will you be making shorter cables for the KX2? I really like the plug-n-play capabilities and the size of the DigiRig and want to boost my power up to 5 watts without getting the error. Please let me know if you have some ideas!
Thank you!!

What kind of antenna do you use and what sort of SWR do you get at the target frequency?
It is possible that a choke balun at the feed point may be needed.

Hi Denis,
I’ve found out more information after posting my question. I have used 2 different antennas. I have an MFJ 40-10 End Fed Low Power and an Elecraft AX1. Each one is fed with a different type of Coax. I have a tuner in the KX2, so I can get to 1-1 on SWR. I’m using a Windows 11 laptop to run WSJT-X and FT-8.
I have scavenged a lot of YouTube videos and tried adding Ferrite snap on beads to the wires. The best I could get was maybe 1 watt, though usually it was less before I got the audio error. This evening I found a video where a gentleman was discussing a number of audio interfaces that he had and one of them was DigiRig. He mentioned that it was a great device, but he found RFI issues with the USB “C” cable included and that the rig operated great with a different cable. I didn’t have a workable spare, so I put a ferrite bead at each end of the USB C DigiRig Cable and then would the cable through a Toroid that I had until I had 10 turns. I experimented by bumping up the power until I could get 5 watts. I haven’t gotten the error since and am excited to take the DigiRig and my KX2 out into the field. It doesn’t sound like this cable is a common problem, but I am glad I was able to figure it out. Now that I have the cable working, I will keep on using it.
I also wanted to thank you for responding to my question so quickly!!
Thank you for your help!

1 Like

Thanks for the update. I’m glad to hear you got the issue figured out.
For those in similar situation I would recommend short, shielded, ferrite choked USB cable:

1 Like

So I ran into the same problem and found this thread on the topic & wanted to add my experience. I want to say first that I purchased the complete Digilink package with all three coil cord cables. I am using a Lenovo laptop that has the typical two wire AC cord P/S.
WSJT-X was giving me the error and crashing when I tried running anything above 5W which is the lowest my FT-897 would go. I swapped out the USB cable with another uncoiled style that I had handy and the crash was hit or miss. But an improvement enough that I knew I was on the right track chasing RFI. I also by chance heard some RFI in the amplified speakers connected to a desktop computer when I was running 30W output. Next I tried a snap on ferrite bead on the Digirig branded USB cable at the computer port and it made no improvement. The following day it dawned on me that the laptop isn’t grounded. So I bent a paper clip to loop around the USB outer shell and clipped it to the ground lug on the ATU. Problem solved. Even at a full 100W out, no RFI glitch.

I’m going to look at the Digilink schematic and test the supplied cables to see if ground is carried through from the outer shell of the USB cable to the radio chassis ground lug. More tests to make.

1 Like

So I bought the short USB-C/USB cable with the molded in RFI chokes and it solved the problem. I’d highly recommend it over the pretty Digilink coiled cord. I bought the package from Gigaparts and it came with the coil cord, if you have the option to get the cords individually, get the cord with the RFI chokes.