WSJT-x settings for digirig/kenwood TS-440 combo

I’m trying to use a Digirig Mobile with a Kenwood TS-440s to do FT8. The Digirig was ordered with this in mind and was configured for this use. Does anyone know what the settings in WSJT-x would be to make this work?



anyone? still looking for info…

Please start with basic setup instructions per “getting started guide”. You can initially set rig to “none” and make sure audio and PTT works before dealing with the CAT control settings. After you get some QSOs with basic setup look up “Kenwood TS-440 WSJT-X CAT” for transceiver and serial port settings recommendations (not Digirig specific). Here’s one of the topics I found:

Share your findings here when you get it working.

hi denis. thanks for the reply and sorry for the delay. life has a tendency to get in the way of things.

as it turns out, I’m the OP of the post you linked to in your reply from the wsjtx groups site. those settings seemed to work fine with the Signalink I had at the time. they don’t seem to work now.

I also tried the settings from another post here, “WSJT-X settings for Kenwood TS-440S.” similar to the settings from my original wsjtx groups post. that didn’t work either.

so, I’m in a bit of a bind here. do you have any other recommendations?

BTW, I am able to get audio into WSJT-X from the 440 in both the “None” and “Kenwood TS-440s” configs in the software. I am also able to key up the radio and get audio on the air.

thanks again…


With PTT and the audio working both ways you should be able to log some contacts.
Please confirm that this is the case. That will leave us with optional CAT control configuration.

hi denis. thanks again. I’m not sure what’s happening now. WSJT-X is receiving incoming audio from the 440 via the DigiRig and I’m able to decode transmissions.

but, outgoing audio is an issue. I see the outgoing audio on the DigiRig entry in the win10 sound control panel, but it doesn’t seem to be getting to the 440. I tried turning it up to see if I get any ALC response, but there’s none.

I have the software’s radio section set to “none,” and the PTT set to VOX. I was hoping to use VOX, but without any audio getting to the radio, that won’t work.

on the CAT side of things, still with WSJT-X set to “none,” if I select RTS for PTT with COM6 selected (the assigned com port for DigiRig) and hit Test PTT, I get a quick relay click from the 440 and a box with a bunch of HamLib errors.

so, I’m stumped. any more help you can provide would be appreciated.

thanks again…


re. audio output: you can plug regular stereo headphones into Digirig’s audio socket and confirm that the audio is present on the output. When you trigger tune or TX you’ll hear the tone on one side.

re. PTT: if you get errors during the transmit then you are dealing with RF in the shack which disrupts USB serial or both. See the corresponding section in the troubleshooting guide. PTT by RTS is a correct setting.

thanks again. outgoing audio is getting to the DigiRig per the headphone test. it’s not getting to the rig. could be the cable or the rig. the rig just came back from Jahnke Electronics, having been checked out and tuned up. I’ll have to do more testing.

as far as the PTT is concerned, it’s not RFI as WSJT-X won’t put the 440 into transmit. it’s just a quick (half-second, perhaps) relay click upon hitting Test PTT with RTS enabled. I’ve not yet been able to transmit from the rig with WSJT-X.

so I’m stuck.

Did you try lowering TX power to a minimum, using dummy load and other diagnostic methods outlined in the troubleshooting guide?

I’m not sure why you keep asking about transmission issues. as I’ve said a couple of times now, I haven’t been able to transmit at all with WSJT-X and DigiRig. therefore, the errors are not being caused by RFI. if you can’t put the transceiver into transmit, how could you have RFI issues?

just to make sure, I left everything connected, left WSJT-X running, went to a phone portion of the band, and manually transmitted voice at 100 watts on the 440. no errors or issues with RFI at all.

I did consult the troubleshooting guide several times over the past several weeks and tried what I could with the setup I have.

Relay click would indicate the attempt at transmitting. Few things to try:

  1. Same PTT by RTS attempt with only audio cable connected. Do you get hamlib errors?
  2. Same PTT by RTS with no transceiver cables connected. Do you get hamlib errors?
  3. Same as #1 with minimum TX power. Even better if with dummy load. I’ll keep asking this until we have this data point. hamlib errors?

Let me know the results.