Xiegu g90 + Digirig + Winlink will not TX

I’m trying to use Winlink and Vara HF with my g90 and digirig. It seems like I have everything setup correctly, and it seems like Vara HF is hearing audio from the radio, but I cannot get it to TX.

I am able to use WSJT-X via flrig to the digirig and g90 and make contacts that way, so I don’t think it’s a hardware issue. I must have something set incorrectly somewhere. Do I need / can I use flrig as the CAT control, or does Vara HF/Winlink handle that? I’ve tried both with and without flrig and various settings for com ports, ptt, etc and nothing works.

I know the digirig is on com 5 as I can see it in Device Manager, and it’s working with flrig/wsjt-x on com 5. What settings do I need to use for Vara HF and Winlink?

Current settings…
Vara HF:
TCP Ports - Command: 8300; Data: 8301; KISS: 8100
Accept 500 Hz connections: checked
Tuner enhancement: checked
CW ID: unchecked
KISS Interface: checked
RA-Board PTT: unchecked
Syslog: unchecked
Device Input: Microphone (3- USB Pnp Sound Device)
Device Output: Speakers (3- USB PnP Sound Device)

Winlink Vara HF settings:
Virtual TNC host address/name:
Virtual TNC Command Port: 8300
Data Port: 8301
Session Bandwidth: 2300
Enable 2750 Hz channels: unchecked
Vara Modem location: C:\VARA-HF\VARA.exe
Automatically launch Vara TNC when session is opened: checked
Show the Vara TNC screen when it’s loaded: checked

Select Radio Model: Manual
USB Digital: selected
Serial port to use: Com 5
Baud: 9600
Enable RTS: checked
Enable DTR: checked
PTT serial Port to use: External

What else am I missing here?

Try unchecked RTS and DTR in CAT section, select Digirig’s COM port in PTT section with RTS checked.

Try unchecked RTS and DTR in CAT section, select Digirig’s COM port in PTT section with RTS checked.

Same result. No TX.

Ok, I finally got the radio to transmit by using the following settings. However I haven’t been able to connect to any RMS stations. I will keep trying though.

Radio Model: Icom 7200
Icom Address: 76
USB Digital
Radio comm port: com5
Baud: 19200
Enable RTS: unchecked
Enable DTR: unchecked
PTT Port: com5
Enable RTS: checked
Enable DTR: unchecked

1 Like