Xiegu G90 - no audio out

Just finished a troubleshooting session with operator setting up Xiegu G90. He was struggled with no audio from the transceiver. Turned out that it was due to the mode setting; it should be set to “U-D (upper side band digital)”. Older firmware like mine (1.75?) doesn’t have this option and works on regular USB (upper side band).

Other relevant G90 settings: line out level, line in level, and input source (line in for digital).
Tour of older firmware settings for digital modes:

I worked on this for 2.5 days I was using USB as soon as I changed it to U-D it took right off. Thank you for the help.
KE8MWQ 73

1 Like

On mine, pre-software upgrade, JS8Call would put out audio on the first USB transmission, and then all subsequent transmissions would have no actual audio output most of the time. I upgraded firmware and selected U-D, and it now works.

Unfortunately it seems that FLRIG hasnt caught up to the new firmware, and U-D cannot be set through FLRIG. It has to be set by pressing the mode button on the radio. This precludes remote operation by VNC. If anyone has found a fix for this please let me know.

1 Like