Yaesu FTM300DR starts transmitting when audio cable plugged in

Hello everyone, newbie ham here. I have a new Yaesu FTM300DR, and a Digirig with the Yaesu MiniDin10 9600-baud cable and USB A to C cable, all purchased directly from Digirig.

I followed the getting started guide, and went to plug the minidin10 cables into the Digirig. The black cable went into the audio port, and green into the serial port as the info on the minidi10 page instructs.

I realized that my radio started immediatly transmitting when I plugged in the audio cable. I checked to make sure hardware flow control was turned off. With the serial cable unplugged, just plugging in the audio cable also makes it transmit (on the Yaesu’s B band, as that is the one set for data modes in the menu.)

I put ferrite chokes on the USB A to C cable, on the audio and serial cables that plug into the Digirig, and tried running the laptop on only battery power, and both USB ports. New Asus laptop running Windows 10.

The only program running on the laptop is NMEATime. (Also the NMEA output from the Yaesu on the serial port is unreadable to the NMEATime program, but that’s an entirely different problem.)

What am I missing here? Is the laptop’s USB ports or software triggering the hardware PTT somehow, and what settings do I look for to fix that? Thanks in advance.

-Justin N5JWR

Before connecting the radio, select RTS over Digirig’s COM port as the PTT method in the digital modes software of your choosing. That will release the RTS line which controls the hardware PTT line in the audio side of the cable.

Hello sir, thanks for replying. So I just tried what you suggested with WSJT-X and JS8CALL. Rig control is off in both programs, I set the PTT to RTS, and Com3 which is the digirig. Both programs come up with error messages, and stay in the loop of the error message if I push cancel. I tried it both with the digirig disconnected from the radio, and plugged in, radio continued to stay in transmit while plugged in. Tried both with and without serial portion of the cable connected, same behavior.

Ok, so it appears my problem might have been the NMEATime program. I opened task manager and force quit it, and now WSJTX and JS8Call both can successfully test the PTT, and the radio no longer continuously transmits when the audio cable is plugged in. I have no idea why the NMEATime program should be doing anything but listening for an incoming GPS signal, but clearly something was incompatible and I will have to find another time sync program. I went with that one since it operates independently from internet time servers (plan to use this laptop for off-grid comms) but I’ll have to find another solution if it’s going to mess with the Digirig so badly. K0TX, thank you for the help.

1 Like

Digirig uses a popular UART chip (Silicon Labs CP210x) which is often used in other hardware such as GPS receivers. It is possible that another software decided that it found a GPS when you connected your Digirig to computer and locked up the serial port.

1 Like

Sorry to resurrect this threat, but I finally had some time to work on radio stuff again. I tried a different GPS time sync program (GPS2Time) and once again I experienced the same issue, when I tried to connect through the comm port, my radio started transmitting again. I shut off the program, verified that RTS was selected in JS8, and that the transmit button in the JS8 settings menu would turn on and off the radio transmit.

I tried a different USB port on the laptop, same problem.

I gave up with GPS and opened PinPoint (APRS client) turned off the GPS input in the menu, turned off beaconing, and configured the TNC options the same as my port settings, the ones shown on the Digirig getting started guide. I tried connecting to the TNC (Digirig) to listen for APRS packets, and once again it caused my radio to start transmitting.

I got out my old laptop, installed the drivers and set up the Digirig and PinPoint, and it also caused the radio to start transmitting when I try to connect to the TNC to listen for APRS packets.

I have no idea how to fix this, and if it’s a hardware problem with the Digirig or incompatibility with the Yaesu FTM300DR or operator error on my part with software settings (most likely.) I’ve tried with the audio cable connected and the serial port disconnected, and it does the same thing.

If you have any further suggestions I’d appreciate it.

When you say “connect to the TNC to listen for APRS packets” do you refer to a software TNC simulator or some hardware (internal to the radio or separate box)?

In case of software simulated TNC like soundmodem, the bit converted to sound inside of the computer and sent to the radio via the audio cable. If you are using the hardware TNC then the bits are sent via the serial cable and connected to audio inside of TNC.