Yet another Anytone D878UVII Plus Issue

Good morning. I’m somewhat new to the radio world, trying to get it all in one sock, as it were, so please bear with me.

Issue: D878UVII Plus does not appear to connect to laptop using Digirig Baofeng cables kit for Digirig Mobile cable set. No com port is assigned by laptop.

What I’ve done so far:

  • D878UVII Plus with firmware 3.0
  • Surface 8 Pro laptop, Windows 11
  • Digirig Logic Levels
  • Baofeng cables kit for Digirig Mobile (using black cable into Audio socket)
  • The Silicone Labs virtual com port driver was installed before I connected the Digirig, and the Digirig is now installed and appears as com port 8 and appears in the sound control panel as USB PnP Sound Device.
  • 878 is fully functional.
  • I use Powerwerx speaker/mic regularly with no issues.
  • I can use the OEM programming cable plugged into the Surface 8 and the 878 immediately gets a com port and functions properly, i.e., I can read from and program the 878 with no problems.
  • Using the black Baofeng cable, the Surface 8 does not detect the 878.
  • I read a topic where one user had issues with the 878 mic socket, so I did a bit of twisting, pushing, cussing, etc, with no change.
  • I also have the Anytone AT-D578 Cable for Digirig Mobile which I have used to successfully set up the D578 mobile radio to use Winlink and Vara FM. I can plug the 578 cable into the Digirig and everything works as expected, no issues.
  • I have a friend who has the same Baofeng cable set that I have, he was able to use his cable to successfully set up his 878 HT. I borrowed his cable and I get the same results as with my cable - no connection.
  • I have not yet compared his 878 hardware version/firmware version to mine but will do later this week when he’s available to do so.

So, my thought is that the Baofeng cable will not work on my radio for some reason. Everything else in the chain from laptop to USB-C cable to Digirig works properly. The Digirig work properly with the 578 cable and radio. The 878 works with the OEM programming cable and the laptop. The only thing I can see that doesn’t work (so far) is the Baofeng cable(s) one of which is known to have worked on a different 878.

Sorry about volume one here, but I can see you like more info than less. Anyway, what else would you like to know?

Thanks in advance!

Addendum: I also used the green chirp cable on the off-chance it would connect, but same-same. laptop did not detect the 878 using green cable either.

Thanks for the support, but I’ve got it working now. Switched antennas. Bye.

Thanks for reporting back with your success! Congratulations.

FWIW, switching to a remote antenna is usually a way to fix RFI.

73 Constrainted

I’ve having the same problem, what did you do to fix the problem?

Hello. I have a 578 Anytone that worked fine, so I disconnected its’ antenna and used an adapter to connect it to the 878 and it worked. The 578 antenna is a dual band base antenna, where the 878 antenna is a 15" whip, Diamond as I recall. Best of luck!

1 Like