Digirig, Mac, and FT-891

Would love some help getting my FT-891 to be recognized by WSJT (not sure if this is a Digirig or WSJT, Yaesu issue).

This is the error that I am getting. When I hit the “TEST CAT” button the radio starts to transmit, or at least the red light comes on. Then after 10-15 seconds I get this error. I have tried all the combinations of the serial ports and I have the radio set up as follows:

Digital menu settings for the Ft-891

05-6 Cat Rate: 38,400
05-7 Cat TOT: 100msec
05-7 Cat RTJ: Disable

08-01 Data Mode: others
08-02 PSK Tone: 1500
08-03 Other Disp: 1500
08-04 Other Shift: 1500
08-06 Data LCUT Freq: 300
08-07 Data HCUT Freq: 2800
08-09 Data In Select: Rear
08-10 Data PTT Select: DAKY
08-11 Data Out Level: 50
08-12 Data BFO: USB
16-03 HF PWR: 30
16-10 Data Mic Gain: 50

Thanks! Monty

I do not have your radio, or use a Mac, but I do not want your question to go too long without an answer.

Since you have PTT method set to CAT, you are mixing both CAT and PTT when you test CAT. Have you tried setting PTT to another method and then testing CAT separately?

FWIW, many operators use CAT to control VFO and mode, and use COM port for hardware PTT.

Denis @K0TX has written a guide, Troubleshooting Digital Modes – digirig. You can also view threads discussing the Yaesu FT-891:

Latest yaesu-ft-891 topics - Digirig Forum

73 Constrainted

The peculiarities of FT-891 are described in this post.

The bottom line is that you’ll either have Digirig connected alone or Digirig and also a direct USB cable from transceiver to the USB. In former case you’ll see the COM port from Digirig, in latter you’ll see Digirig’s COM port and also radio’s own COM port. Use Digirig’s COM port number for PTT by RTS, if you have CAT connection then use radio’s COM port for CAT control. If direct cable to radio is not connected then disable everything in CAT section of the software configuration (rig=NONE).