Digirig on Windows 10

I was recently gifted a Windows 10 HP Spectre 360 Laptop/Tablet which had a clean install in W10 and now a brand new battery, which I installed myself. I had virtually no issues setting up Digirig to run WSJTX on my 2012 MacBook Pro from my FT-818. However, I’ve tried unsuccessfully to get the right settings on the Windows 10 machine. The Digirig is recognized when first plugged it into the laptop but the USB ports don’t show up in the list in the Radio settings. Testing CAT control fails. I tried the USB port as well as the USB-C but no go. Tried installing the driver as suggested in the Troubleshooting here, which is the same as the driver download from Yaesu’s site but could not get that to make a difference. Is there something I’ve overlooked?
I did try a workaround that I saw in another forum: I added Flrig to the laptop and used it as the radio setting and WSJTX started to decode but couldn’t get the radio to transmit through CAT.
Any and all suggestions to get either setup working would be appreciated.

Rod,
Let’s go to the beginning of the setup process. Can you check the Device Manager? With Digirig plugged in it should show these components (the COM port may have a different number):

image

Thanks for jumping in and assisting.

Yes, I got that far but the com port numbers do not show in device manager.

Here’s a Screenshot of Device Manager so far.

Rod VA3MZD

Rod Murray

99 Riley Cr

Fergus, ON

N1M0B8

Canada

52565F3B798943009AC542DF366E46F1.png

Yeah, that needs a driver: CP210x USB to UART Bridge VCP Drivers - Silicon Labs
Other issues also may need to be addressed, but not related to Digirig.

Oh My! Success!

So yesterday, I worked on this for a few hours and got nowhere. Each time I tried, negative. Tried a few times to update the driver. Nothing. Downloaded the same driver from Yaesu, with the hope that would give me a better shot…Still nothing.

When I opened Device Manager a few minutes ago, took a screenshot of the devices/ports, emailed back, there was no Port Number as you could see.

I clicked on the CP210 and was given the option to Update the Driver.

The Port # appeared, and when I jumped over to WSJTX, Com 3 is in the Port list! Selected. Tested CAT. Green Light!

Go! Decodes!

I haven’t messed with a Windows PC since XP and I thought I was doing everything according to your Instructions but no go last night and this morning. Now, the driver is updated and I’m all good!

Thanks for the help! Still puzzled as to why I couldn’t do this before.

73

Rod

52565F3B798943009AC542DF366E46F1.png

Rod, thanks for the update. Glad to hear we got it sorted out.
If you would like to contribute further, please post the relevant transceiver settings you used in your FT-818 and any digital modes apps configuration screens.

Yes- I’ll follow up in the forum for the benefit of others!

Rod Murray
Fergus, ON

Canada

1 Like

Tested transmit and all ok.
I used the default settings for WSJTX and they seem to work.

Thx again.

Rod VA3MZD

Rod Murray
Fergus, ON

Canada

1 Like

We call that reason “Windows”, HI.

I’m still a little miffed at why I could not update the Driver last and that it seemed so easy today after Denis replied to my plea. I’m a Mac user and haven’t messed with Windows for some time. Perhaps if I was a little more experienced…

Bottom line-

From Device Manager, I right clicked and was given the option to update the driver, since the device was visible but wasn’t connected/recognized in one of the ports. Since I’d downloaded it a few times last night, even direct from Yaesu, I selected On My Computer and navigated to Downloads. Once the Driver was updated, the Com Port 3 was listed in Manager beside the USB device.
I opened WSJTX and in Settings—>Radio, I could use the drop down menu to select Com 3 and once that was done, I selected most of the defaults. The Test Com was initiated and the green light was returned.
I then noted the decodes began to work. One more test of Transmit and all was good. I will add some screenshots of the Settings used for others following this thread.

1 Like

To reemphasize. To get the Digirig working one must download the new CP210x USB to UART Bridge VCP - Silicon Labs Driver which is available on the Yaesu FT-818 webpage or by a Web search or link from the Digirig support page:
https://www.yaesu.com/indexVS.cfm?cmd=DisplayProducts&ProdCatID=102&encProdID=36B7B98621AF7554C9A03C8B190C5079&DivisionID=65&isArchived=0

Here are the screenshots of the settings used in WSJTX:

Hope this all helps!

Rod VA3MZD

2 Likes

Thank you, I to am having troubles setting up digirig and my ft818. will try these settings
Tim kg7fxn

Are you on Mac, Windows or Linux?

I have it installed on windows 11.

1 Like

I am having issues as well with my FT-818 not having an output.
tested at 6W, 5W, 1W with the same results.

Momentary press on F button - MTRalc - no bars on transmit
Momentary press on F button - MTRpwr - no bars on transmit

Windows 10, 64-bit PC, with Drivers up to date.
I turned off the Auto Gain Control in the advanced settings of my PC (for USB audio input/output after testing multiple configurations as noted below). I also adjusted the Microphone settings for the digirig mobile to pick up properly in the WSJT-X software. As for the Speaker output, I have adjusted the levels with getting no results.
The cables came with the digirig kit. serial to ACC. Audio to Data.

FT-818 settings:
03 9600 MIC = 50
14 Cat Rate = 38400
24 Dig Disp = 0Hz
25 Dig Mic = 50
26 Dig Mode = User-U
39 Pkt Mic = 50
40 Pkt Rate = 9600
(Momentary press on F button - AGCoff)

I am getting audio out of the digirig (tested with headphones, about 1/4 audio level of laptops port).
I also tested with Function menu items 03, 25, & 39 up to 95% with no change.

I will take a screenshot of my settings and post them when I’m in the shack.
Hopefully they will help.

Rod
VA3MZD

Rod Murray
Fergus, ON

Canada

Here are my Settings Screenshots for WSJTX

I hope these are helpful.

Let us know if you are successful!

Rod

VA3MZD

EN93

Here are My FT-818 Radio Settings-

03 9600 MIC = 50 - same
14 Cat Rate = 38400 - “
24 Dig Disp = 0Hz - “
25 Dig Mic = 50 - “
26 Dig Mode = User-U - “
39 Pkt Mic = 75 - different
40 Pkt Rate = 9600 - 1200 - different

Also -
45 RF- GAIN

1 Like