Digirig with APRSdroid

Hello, all. I managed to get my WoAD/digirig issue resolved. Thank you all for the help on that. My new issue is using the digirig with APRSdroid on my Samsung S-10 and a Yaesu FT70 and FT60. When I hit the “Start Tracking” button in APRSdroid, my radio goes into transmit, but it hangs there and no data is transmitted. It’s just a hot mic. The radio stops transmitting when I hit the “Stop Tracking” button. I have TNC (KISS) via USB selected with a baud ratio of 115,200. I did try all of the baud rates, but nothing changed. Any advice?

Thank you,
Wayne KB4DSF

You can check if there is audio output from Digirig during the transmission by plugging in regular stereo headphones into audio socket. You should hear audio on one side. Id you don’t get the audio then software is likely not configured to use Digirig’s sound card.

You need to select connection protocol Audio (AFSK) after plugging the Digirig into your phone.

Thank you for your response. How do I get the radio to go into xmit if I switch to AFSK?

The Digirig will handle XMIT by sending a signal over the audio cable. You do not need the serial connection, only the audio connection. I didn’t modify my Digirig in any way and it works correctly. When using with an Anytone 878 I did have to increase the TX delay, but found the default settings work fine with Yaesu radios.

By the way I have used a Digirig with an FT-70 and an FT3. I did have to shave off some of the plastic on the official Digirig Yaesu cable in order for it to seat properly in the FT3. Worked as is with the FT-70.

Ok. Im only connecting the audio cable to from the digirig to the radio. Are you using the vox capability of the AT radio to handle the PTT? I apologize for all of the questions.

AFSK with the FT70?

Yes, Audio Frequency Shift Keying. Basically the app you are using handles the audio tones much like a software modem program like Soundmodem or Direwolf. The app itself is passing the audio tones back and forth to the radio through the Digirig.

1 Like

Well, I tried that, but I’m still not cracking the code. I truly appreciate your help, though.


Thanks for the reply, Denis. When I plug the digirig into my phone, the phone asks me if I want to open WoAD or APRSdroid. The digirig is working with WoAD, but I have had no luck getting it to work with APRSdroid, yet. I had one response suggest I’m supposed to select AFSK rather than USB within APRSdroid, but that’s not solving the problem. So, my question is how do I make sure I have APRSdroid configured to work with the digirig? It seems I’ve tried every combination of selections, but I’ve yet to Crack the code on this one.



Here’s one more piece to the puzzle. When I select USB within APRSdroid and start tracking, APRSdroid does find the USB device and garners permissions to use it.

There was some issue with APRSdroid compatibility, which community is trying to address.
Please check out this post for more information:

Got it. Thanks for your help. I hope this gets figured out, soon. APRSdroid with the digirig seems like a great tool.


1 Like