FT-891 Into digirig mobile for JS8CALL

I got my 891 setup to do FT8 on WSJTX and everything (seems) ok but trying to setup the settings in JS8CALL i must be missing something because it just wont line up. Anybody willing to share their JS8 settings with me?
After thinking it over and trying to follow three different YouTube guys that all had different settings I realized i had no clue what was changed and not so i did a factory reset till i get some info from someone that can help!

Lots of FT-891 related info is in this thread:

JT8Call settings are pretty much the same as WSJT-X settings.

OK NOW I see where i was jumping off track!
Following KB9VBR i was going into the wrong settings!
In the video he was in WSJTX and i was looking in JS8 CALL :person_facepalming:


Nope followed every friggen video and only one that even seemed to get results was the KB9VBR
I can get to the point of testing the cat and get a green light there and receive incoming signals but no response from the radio or wsjtx if i change bands respectively.
I factory reset after trying each persons video of setup. :face_with_symbols_over_mouth:

Do I understand it correctly that CAT control does work as expected in WSJT-X but not in JS8Call?

No I mispoke I was thinking of my QSO’S I made on my 7300. I have made none on the 891

KB9VBR’s video doesn’t show the connection of the USB cable that runs separately between the computer and the ft-891, which must exist for CAT control.

His video only shows the use of the Digirig as the audio source to the ft891.

With the ft891 kit is a separate usb a to usb c cable. That completely bypasses the Digirig, running from the computer to the radio. Of course the USB driver must be loaded first.

Then select the ft-891 as the radio, set up the port and voila you should have CAT control. It works well on mine.

1 Like

Yup i have it on.
I can receive incoming and operate push to talk from the setting page but nothing else.
I change bands in the app or on the radio there is no response on the opposite end.
The sent panel populates that i typed a message to send but pretty sure thats the end of it

PTT is not done through CAT control. It’s done through the Digirig. CAT control is separate from the Digirig.
Unfortunately I have to leave, but maybe this video will help:

I’ll check back later tonight. Good luck.


Perfect! Up and running and making contacts on WSJTX! THANK YOU!
Now to try to operate JS8 :grin:


And that is that!
No idea what the big difference is from all the other videos but ya got me going on WSJTX and JS8!
I bow to your superior knowledge my friend! :wink:

1 Like

Thanks for giving the news of the positive result in the end!

73 Constrainted

I got no clue. I followed and paused the video each setting or adjustment on all the videos and this one worked. No idea why but im not going to argue lol

1 Like

Good job! I’m glad it worked out.