FT-891using WSJTx & Windows 11 Surface Go 2

Having problems with the digirig contected to a FT-891 and configuraing the control setting in Windows 11 and WSJTx.
It seems that all is properly set; however, my receive control level meter is above 87db and in the red. My decode indicator flashes when recieiving.
I have moved the digirig cable from Serial to Audio and back and forth with no change in the Receive control level meter indicator.

Do you use the cable with black MiniDin6 connector from FT-8xx kit? The TRRS end of it should go into Digirig’s audio socket. With FT-891 there is nothing connected to Digirig’s serial socket. More on that here:

Although mechanically identical, the electrical functions of two Digirig’s sockets are different. There is no cost to trying connections in this case, but I would discourage this kind experimentation as a troubleshooting method.

Denis,

Thank you for responding to my dilemma.

I now have the Digirig connected from the ‘Audio’ port to the FT-891 using the cable I purchased through Digirig. The USB cable (C to C) is connected to the Surface Go 2 from the Digirig USB port.

In the WSJTx program, I have selected COM3 from the Device manager list Ports>Silicon LabsCP210x USB to UART Bridge COM3). There are no other COM Ports listed.

Under Device Manager list Sound>USB PnP Sound Device is shown when I plug in the Digirig.

In the WSJTx program, Under Settings>Audio I have the Input set to Microphone (2- USB PnP Sound Device) and the Output set to Speakers (2- USB PnP Sound Device) These are the options that show up; along with the computers’ selection.

In the WSJTx program, Under Settings>Radio>CAT Control>Serial Port=COM3

In the WSJTx program, Under Settings>Radio>PTT Method>RTS=COM3

With these settings, pressing “Test CAT” I get a “Rig Failure” error message.

What am I doing wrong?

Steve

As outlined in that other post, the CAT control is not available through Digirig with FT-891.

You should either select “none” for the rig in WSJT-X settings or connect your Yaesu directly to the computer using a separate USB cable and in CAT configuration select the COM port added by that separate direct connection. With your tablet you’ll need a hub to split USB into two ports or just stick with audio/PTT through Digirig and no CAT control which is optional.

I installed the hub on the Surface Go 2 and connected the USB cable from the FT-891 to the Hub on the Surface Go 2. Everything appears good; however, I am getting no Band Acitivity on WSJTx and the Level Meter is red and all the way above 87db.

Sorry to be such a bother on this issue, just cannot get it to work.

Steve

In Digirig’s recording device in Control Panel, please adjust the level down and make sure the AGC is disabled. If level is too hot with the sensitivity at the minimum, you can activate a hardware attenuator in Digirig. More on that here: