FX-4C: digirig in and out both work, but not together

I have an FX-4C that I haven’t been able to get working for digital using its built-in interface. So I’m trying my digirig as a workaround.

After some confusion with cables, I now have it seeming to work fine in that I can receive and decode FT8 with the green cable plugged in, and I can PTT and transmit audio with the red cable plugged in. However, when I plug the red cable in it causes the received audio to drop off. So I can do FT8 if I plug and unplug the red cable every 15 s :slight_smile: .

Any suggestions how to work this? Many thanks as always!

I do not own this radio, but I do not want your question to go too long without an answer.

If you are using Windows, make sure AGC is off for the Digirig audio device. I use mmsys.cpl to set this. Are you on battery power or power supply? What is the initial level of receive audio and how low does it drop? I run WSJT-x with the level to be between 50 and 60.

Does this radio adequatly attenuate RX during TX? Are there settings for that?

Are you selecting the Digirig audio devices? The FX-4C has a built-in audio card:


Denis @K0TX has written a guide, Troubleshooting Digital Modes – digirig which will give you a step-by-step approach.

73 Constrainted

1 Like

This can be related to the radio’s speaker output using BTL design as discussed here:

With only the headphones cable plugged in, can you check that there is continuity between the sleeve contact on the Digirig’s end of the cable and radio’s chassis?

If there is none, then the cable will have to be modified by disconnecting the sleeve on the headphones connector.

1 Like

Thanks very much for your replies!

Indeed, with the headphones plugged in there is no connection to the radio chassis/ground. There is with the mic plugged in. So I tried reducing the headphones cable to only the tip. The audio still shows up (albeit with sharp harmonic artifacts overlaid) in WSJT-X, but it still drops out when I plug the mic in. I then tried reducing the mic cable to only the sleeve / ground and confirmed this is enough to make the audio drop out. Plugging something else like the stock handmic in does not affect the audio.

I’m running Linux, but I will try checking the AGC on the Digirig. If I have the audio at about 60 dB, it drops to zero when I plug the mic cable in. I can get the receive dB to go back up by really cranking the volume on the radio, but the result is just noise without the signal that was there before.

The FX-4C has a somewhat different built-in interface compared to the newer FX-4CR. And it seems not all FX-4C have the same interface either. I haven’t been able to get my FX-4C built-in audio interface to show up on my USB tree at all.

Well, I had a separate USB audio interface for connecting headsets to my phone. It looks like it works to run the receive audio into the laptop using that, while using the Digirig for the mic/PTT line. I’m going to try making some actual contacts with this frankendigi.

Let me know if the described behavior makes some kind of sense and there’s more worth trying. I could also imagine making this all work via solid state relays but it feels pretty silly :slight_smile: .