Issues with FT-450D CAT control

I’ve been using an AECreative CAT cable to interface my FT-450D with FLRig and WSJT-X. No issues at all…plug it in, select FT-450D in FLRig and it’s connected and being controlled by my computer.

I got Digirig (RS-232 version) to consolidate my cables but I can’t get CAT working. Audio is working fine. I just keep getting a Transceiver Not Responding error in FLRig, with the default FT-450D settings. Curiously, when that happens, the radio gets stuck in TX and I either have to turn it off or remove the USB cable and plug it back in.

Is there anything I should be changing to get Digirig working? Currently it’s just a (very light) paperweight.

For reference, relevant radio settings are:

D-TYPE - USER-U
CAT RTS - Disable
CAT TOT - 10
CAT RATE - 38400
Needs to be in USB-Data mode

I’ve tried enabling CAT RTS and changing some of the RTS-related settings in FLrig but no luck.

I’d appreciate any help!

The radio keying up means that the software still tries to use RTS signal for its legacy purpose - hardware flow control. Digirig uses that signal for PTT triggering. I suspect you’ll get this effect even without the serial cable connected because PTT line is connected via the audio cable.

To accommodate the transceivers that might insist on the hardware flow control, the RS-232 cables currently offered in store have their RTS/CTS pins connected on the transceiver side to loopback hardware flow control.

If you use older cables, we can try swapping your cable out and see if that improves the situation.

Thanks for replying. I may have been unclear in my original post. I’m using a brand new Digirig 1.9 meant for RS-232 and the Kenwood TS-480 cable set. Those should be working in concert, right?

If you get CAT control works with another interface and does not work with the same settings using Digirig’s serial port then there must be some hardware or compatibility issue.

You are welcome to send the gear back for re-testing and if everything checks out then I can issue a refund instead of sending back the replacement. Please PM me for arrangements.

BTW: Do you configure the serial port for 1 or 2 stop bits? I would try an alternative setting there.

I have tried both 1 and 2 stop bits. I think at this point i’ve systematically tried just about every combo of settings on the radio and FLRig to no avail.

Yeah, if it’s cool with you, maybe sending back for re-testing is the right move. I’d absolutely love to get the Digirig to work so I can consolidate a bit. I have one for my x5105 and it’s fantastic.

1 Like