Just received the unit and "CP2102N USB to UART Bridge Controller" is the only I get

Just received the unit and “CP2102N USB to UART Bridge Controller” error under "Other in Device Manager is the only I get. Everything I can find online is “you don’t need drivers” but it looks like it does. Nothing under Adapter/Com ports, nothing under Sound cards. Two Windows 10 computers and one Windows 11, all 3 with the same issue. Tried 7 different USB-C cables and same thing. All 3 computers are up to date. Did I got a bad unit? or it really needs drivers? I dont even plugged anything to the radio yet, just the digirig to the computers, thats it. Tried to install the CP210x_Universal_Windows_Driver but Windows says “Unable to install” I may got a bad/wrong version trying to find the driver. I will appreciate any help as is quite frustrating.

@kc4ap That’s frustrating! In my experience with Windows 10 and then Windows 11, I needed to install the drivers for the Digirig UART to be recognized as a COM port. When my OS security would discourage me from installing, I could always find a way with following a “more” link, clicking “keep anyway” or right clicking and seeing some other options.

73 Constrainted

Thanks for saving my Christmas :). I went out there and got the drivers plus some tech docs. With any luck, I will get there.

Have a good Holiday Season

Harry KF0MAB

1 Like

@ford2go Awesome! I am happy I pointed you in the right direction.

73 Constrainted

So everything is solved from this other thread?

73 Constrainted

I am getting the same thing. Device not recognized as a com port.

Installed the driver and get an error “slabvcp.inf” install failed. And that driver, from the link posted above, is for windows not 10 or 11.

That sounds frustrating. Did you try the Universal Windows Driver?


73 Constrainted

About to. Thanks. Will let everyone know.

Jason, here’s the video of the driver installation for your reference: