Kenwood TS-450S "Test Cat" errors in WSJT-X

I purchased the Digirig RS-232, the coiled USB C cable and the TS-450 cable kit direct from Digiriig.
When I push Test Cat in WSJT-X, the rig goes into transmit mode for several seconds and then back into receive. Then a lengthy error message pops up in WSJT-X.
I have tried every possible setting combination I can think of in the radio tab.
I have done a reset on the TS-450S as well; same results. Any suggestions appreciated. I am sure I have overlooked something…

Try setting handshake to “none” and PTT to RTS.
Do you also have audio/PTT cable connected? That is more important than serial CAT.

Digirig audio cable was always connected.
Tried those settings tonight with no change.
As a diagnostic test, I removed the Digirig serial cable and connected a known working Prolific USB to Serial converter to the rig and left the Digirig audio cable connected through the Digirig (each to their own front panel USB socket on my PC) and the WSJT-X tests passed. See attached picture.
Not sure exactly what this indicates but seems useful.
Thanks for the help!

That’s good troubleshooting. Let’s further divide and test.

  • confirm configuration - please peek inside the Digirig to confirm it is set for RS-232. More info here.
  • confirm that Digirig’s serial port is working correctly with the loopback test.
  • I’m not aware of this issue with TS-450S, but there was a combination of factors affecting another Kenwood that caused CAT to not work reliably. If everything else checks out, this is still a possibility.

So with the round Din connector to the TS450 port; which pins do I short for the loop back test?

This is the DIN5 CAT cable. With the TRRS end plugged into Digirig’s serial socket you can loop back the TXD and RXD on the transceiver side of the cable as shown:

Yeah I figured that out by looking at your Digirig schematic and then finding continuity on the cable.

My Digirig is jumpered for the RS232 model.
It passed the loop back test using PuTTY.

More testing using my USB to serial cable vs Digirig serial connection:
In both AC Log and WSJT-X with the Digirig serial connection, the rig goes into transmit whenever the test features are activated. It has the same behavior if I disconnect the Digirig serial cable completely; that is with only the audio cable connected.
With the Digirig Audio only cable connected and my USB to serial connected- the tests pass immediately with no fiddling with settings. The rig does not go into transmit during test activation when connected this way; which is the correct behavior.

It sure seems to me that there is something wrong with my Digirig and/or cables since the nearly 10 year old USB to serial is working where the Digirig is not. Perhaps a defective unit or cable? I don’t know.

The transmit is the result of RTS line activated. This is the intended behavior.

Try following: only connect Digirig’s audio cable. In WSJT-X set rig to “none”, handshake to “none” and PTT to RTS over Digirig’s COM port. You should be able to test PTT and run FT8 as long as you set the frequency manually. Please confirm this works.

Yes this works.

Let’s not try re-enabling the CAT control while keeping PTT and handshake settings unchanged.

Did you mean to try re enabling CAT?

Yes, you can re-enable the CAT control in WSJT-X configuration by selecting the rig profile from the list. Do you still radio transmitting at wrong time?

Thank you. I will do this tonight and let you know.

Same results as before, testing cat results in hamlib error messages.
All settings the same, just chose the ts450s in the drop down. As soon as I set rig back to none and hit test ptt, it all works fine just no cat.

Hi Alan,

The TS-690 is the same as the 450 but adds 6m. I’m using the digirig cables. This config works for me:

I was glad to hear from someone using the same type rig.
No luck with these settings. Same error messages.
Thank you,

Maybe try the 690 profile? Could you post back another screen snip?

Tried the TS690 profile, same results:

And here with the Digirig serial unplugged and a prolific usb to serial adapter plugged in:

Took the rig to my other shack this past weekend. Using windows 11 laptop there. Same symptoms. Using the same ports on the rig that the Digirig uses; I connected my old Signalink and the usb to serial adapter. Worked fine on WSJT-X.
Still no luck with the Digirig.