KX3 WSJT-X no PTT

Windows 10 64B laptop to Digirig to KX3. KX3 cable set.
Followed the video instructions from WC0O. CAT control works ok but am unable to figure out why the rig won’t transmit. Checked the obvious- power, PTT settings in KX3, etc. May be a WSJT-X setting as I’m not getting the PTT test button to illuminate.
73
Marc, W4MPS

Marc,
Please post the screenshot of the WSJT-X configuration. We’ll go over it.

With the help of Denis K0TX, and following Frank’s (WC0O) setup instructions, my Digirig is now functioning beautifully with my KX3. Per Denis’ suggestion, I am attaching 2 screenshots of my WSJT-X configuration with my particular KX3 and laptop FYI.
Tnx for getting me on the right track
73
Marc, W4MPS


2 Likes

Mine is similar- I use 19200 baud, and CAT PTT. I hadn’t seen this earlier or I’d have tried to help.

1 Like

Hello all, I’m having problems getting the TX light to illuminate on my KX3 as well.

In the “Radio” tab under “Serial Port” I don’t have the “COM8” option available though. I have:
/dev/cu.Bluetooth-Incoming-Port
/dev/tty.Bluetooth-Incoming-Port
/dev/cu.usbserial-2120
/dev/tty.usbserial-2120
USB

I’m using a MacBook and a digirig in conjunction with the KX3.

Thanks,
Steve

Steve,
Try lsusb command in the console. That will dump the info on all USB devices. The one that has Silicon Labs in the description is Digirig’s serial port.

ran “ioreg -p IOUSB -l -w 0” and got this:

“sessionID” = 2544906735111
| “USBSpeed” = 1
| “idProduct” = 60000
| “iManufacturer” = 1
| “bDeviceClass” = 0
| “IOPowerManagement” = {“PowerOverrideOn”=Yes,“CapabilityFlags”=32768,“MaxPowerState”=2,“DevicePowerState”=2,“DriverPowerState”=0,“ChildrenPowerState”=2,“CurrentPowerState”=2}
| “bcdDevice” = 256
| “bMaxPacketSize0” = 64
| “iProduct” = 2
| “iSerialNumber” = 3
| “bNumConfigurations” = 1
| “kUSBContainerID” = “82fbc78e-84e5-4015-854d-f17679200709”
| “USB Product Name” = “CP2102N USB to UART Bridge Controller”
| “locationID” = 34734080
| “bDeviceSubClass” = 0
| “bcdUSB” = 512
| “kUSBSerialNumberString” = “561d6d438766ec11966b1f42ef680de7”
| “USB Address” = 3
| “IOCFPlugInTypes” = {“9dc7b780-9ec0-11d4-a54f-000a27052861”=“IOUSBHostFamily.kext/Contents/PlugIns/IOUSBLib.bundle”}
| “kUSBCurrentConfiguration” = 1
| “bDeviceProtocol” = 0
| “USBPortType” = 1
| “IOServiceDEXTEntitlements” = ((“com.apple.developer.driverkit.transport.usb”))
| “USB Vendor Name” = “Silicon Labs”
| “Device Speed” = 1
| “idVendor” = 4292
| “kUSBProductString” = “CP2102N USB to UART Bridge Controller”
| “USB Serial Number” = “561d6d438766ec11966b1f42ef680de7”
| “IOGeneralInterest” = “IOCommand is not serializable”
| “kUSBAddress” = 3
| “kUSBVendorString” = “Silicon Labs”
| }

Do you have a PC to try the Digirig there? Just to rule out any hardware issues.
Also I don’t remember seeing Hamlib errors mentioning USB. Maybe a Mac thing, but typically the error talks about the serial port. Let’s also look at the settings screen for WSJT-X with the CAT ports list expanded.

here’s the current settings. I’ve been trying different options.

See Marc’s screenshot earlier in the thread for settings known to work with KX.
If you want to troubleshoot one area at-a-time, then you can set rig to “none” and work on making PTT work without CAT first (via RTS).

I did try the settings above. Good advice re: setting to “none”. I’ll try that. Thanks

It worked with these settings.

Awesome, now with the PTT working you can go back to CAT setup.
If it still doesn’t work, confirm that the interface is configured for RS-232.