No PTT on new Digirig DR-891


Subject line says it all…while I do have CAT control none of the PTT settings will key the radio. I also tried swapping the audio cable and I took the DR apart and checked the pads on the circuit board.

Any info appreciated. :slight_smile:


I don’t have the radio, but I don’t want you post to go too long without a response.

73 Constrainted

What is the application you are trying to configure?
DR-891 supports PTT through radio’s CAT control, PTT via GPIO3 of the codec and VOX PTT on the right audio channel.

Hi Denis,
I was using Winlink for the configuration, and I tried everything to the point of having to walk away from it. I went and had some lunch, came back and reconfigured and it’s working.

I wish I could give you a definitive solution to the issue that could be passed on to others but I honestly have no idea. :blush:

On my original Digirig I had audio to Com3 and CAT to Com6 and now the new one uses Com6.

I do have one more issue that needs resolution and that is transmit power seems to be lower in Data mode than before.
I have the power set to 30 watts and if I key up in CW mode the wattmeter in the tuner shows that but in Data mode it only shows around 5 watts.

I’ll figure it out tomorrow. :blush:

Thanks for jumping in, and great idea on the new DR for the 891 :blush:



my thoughts are:

even though you have same radio and computer, your box in between is different.
this causes your computer to see ‘new’ coms/audio devices.

try double checking the ‘identity’ of the audio device and adjust the audio levels.

(my thought on the lower ‘drive’/‘output’ going from cw to data)

good luck

What are the transmit bandwidths for CW and Data mode? On one of my radios, which shows TX bandwidth, they can be different by a factor of 5.

73 Constrainted

I just got mine too, the cables that came with it, I have CAT Control, but No PTT. Its Com 4 & 5, same as my older Digirig. But my older one was running on Com 4 & 12 using WSJT

This is my current setting using WSJT which works with the other Digirig with the separate CAT control.

I even tried removing the one cable for USB-A from the radio and I got nothing, errors like crazy.

Anyone able to get this to work by chance? I also called and left a message along with a support message too.

73 Rob - K6IRK

DR-891 makes use of the serial port inside of the radio. Unlike the serial port in Digirig Mobile, the one in the radio doesn’t use RTS signal for hardware PTT. In your setup with DR-891 please set PTT method to CAT. VOX can also be an option (less desirable) if you configure WSJT-X to send the payload to both right and left audio channels.

1 Like