No ptt on raspberry

Pi recognized ttyUSB0
pnp is installed when plugging in digirig with data cable and digirig
connected Yaesu HT with that special cable to digirig to the AUDIO connection
turned off all audio setting except pnp
selected digital output and input mono (tried other combinations also)
adjusted different levels on the pnp’s
website said: USBAUTO=“false” in /etc/default/gpsd but no gpsd in this
directory (gps not installed).

No ptt. PLEASE what am I missing?
THANK YOU in advance!

To narrow down the concerns let’s test the cabling and transceiver by simulating PTT as shown in this video:

Based on the results you’ll focus on either computer/software side or cable/transceiver side.

1 Like

Hi Denis,

Thanks for responding!

No ppt with soundmodem.
Direwolf gave me aprs errors on its monitor even after commenting out all aprs settings.

Did get ptt with flrig: selected digirig com port, ttyUSB0 & rts +v, got constant ptt & couldn’t shut it off only by changing settings.

Went back to mobilinkd until I could figure this out…thoughts?

Thanks Denis

Since you got PTT from flrig we can assume the cable/transceiver side of this functionality is working.

Let’s look at flrig configuration first. I suspect you have CAT control (not applicable in this case) configured there with the hardware flow control tripping PTT. Please share the screenshots from xcvr and ptt-generic sections of configuration.

Hi Denis,
When I try ppt from the ptt button on opening flrig screen:
I can generate ppt but can only turn it off with Init

When I use RTS + 12 v, Init will turn on ptt and ptt button will turn it off.

I also tried silicon labs port instead of ttyUSB0
73, Jay

Here are 5 of the 7 screen shots. The remaining 2 coming in the second reply.

1 Like

Remaining 2 screen shots:

1 Like

I cannot key the radio when I’m at the terminal or the telnet terminal calling my own mailbox or another station.

Waiting your thoughts, Thanks

Hit that big red initialize button!

Tried that, did not work for:
Cat port
Ptt separate serial port

Leaving tomorrow for a week. Please think about it & I’ll check back with you. Thanks

I didn’t see Xcvr section screenshots. Those are the settings for the CAT control and this functionality is not available with your HT so it should be set to none.

Hi Denis,
I have been trying to solve this ptt problem but cannot. I think one aspect of difficulty is I’m running a linbpq node. It’s running fine so will put off the digirig problem for later.

Thank you for all your suggestions. 73 Jay

Hi Denis,
Good progress with the Digirig. I get ptt and a separate monitor shows me tx yet on the qttermtcp is shows red with SABM (not connected). Here is my setup now:
Using QtSoundModem and see waterfall
QtTermTCP shows KISS AND AGW connected
QtTermTCP setup for AGW and KISS to match
In soundmodem: On AGW connecting I get mycall=shows mycall and Destcall=who I’m connect to and “trying”
On KISS I show up on the monitory (SABM) but no “mycall” or Destcall filled in.

Must be something simple at this point but I’m out of ideas. What do you think? Thank you. Jay

Sorry, I’m not familiar with the particulars of the software you are configuring so it is hard for me tell what is going on. If you can describe your results in general terms, I might be able to suggest something.

Got digirig working! It was a port issue, working on soundmodem & direwolf.

Thanks for your time Denis

1 Like

Hi Denis, THANKS for the post regarding the ptt on raspberry pi. I entered the terminal lines from Rocco’s fix and the digirig keys!!. With the soundmodem and digirig I have connection with AGW ports but not KISS so have a little work to do and may have to submit to groups? The mystery is solved. Thanks again, 73 Jay