Not receiving any signals

Just Received my digirig cable yesterday for my (tr)usdx radio I got the radio connect to hp laptop window 11 and using to usb parts connecting to radio and the digirig mobile. iam getting sounds at tx but not receiving anything when i go to monitor. The atu is showing I not getting any power out . the scale on the left side of the screen does not show any db on it I know it will show green at 30db or less and red if its too high.
what am I missing.

That’s frustrating.

What audio driver program are you using? Have you set the input and output of the audio program to Digirig USB input and output? Have you set sound levels with mmsys.cpl? Maybe show a screen capture of the settings to help explain your situation.

73 Constrainted

I don’t that I am using any audio driver program.
went in to mmsys.cpl my playback device is speaker real tek audio default device.
My recording is microphone array real tek default device.
I have CAT running it changes yje band and frequency but PTT seems to put my radio in tx mode but nothing but the transmit sound my atu doesnt show any power out and on monitor i am not receiving any signals, I can do that with out the digirig with a usb soundcard and couple of audio cables

In order to get audio modulation to the truSDX through the Digirig, you must select the Digirig USB playback and the Digirig USB record devices. Does that make sense?

Denis K0TX has explained it well here:

73 Constrainted

1 Like

I have looked at Detecting Components under com ports I have Silcon Labs cp210 x usb to UART Bridge com 7.
under Sound, Video and Game Controllers I have USB PnP Sound Device com 3.
I was having some trouble with my lap top just got it back up this morning.
I am working thru this. I have cat working and the the Test PTT. Still not receiving signals and ATU shows no watts out .
I going to look at my sound set up next.
thanks for you help
Chuck 73

I helped one of my club members to solve this exact issue. He purchased a new Dell XPS13 laptop loaded with Windows 11. The culprit ended up being the Maxx audio software that came installed on the laptop. When I disabled Maxx audio the Digirig worked perfectly. I am told that HP has a similar audio contouring app preinstalled on their laptops. This will most likely be the cause of your problem, assuming that everything else is configured properly. I can confirm that every ham radio application that I have tried works fine with Windows 11, including anything that uses a Digirig as a sound card.

1 Like

I tried removing HP audio switch but still getting the error

check the permissions – in some systems the access to input audio devices is subject to privacy settings and may be blocked for apps (e.g. “sound card device is not ready” error in windows).

Received the shortened usb cable still had trouble with sound output.
Switched to another laptop this is what I am getting

It’s improvement because on the other laptop I was seeing any input. but the highest is 9db.
And I am still not seeding any power out.
the second screen shot
shows my devices.

Not related, but you need CP210x driver on this computer.
Let’s look at WSJT-X’s audio settings. Do you have Digirig components selected there?

OK loaded cp210x driver on this computer .
this is Audio input output in wsjt-x

COM port looks good now.
Audio settings appear to be correct. Do you still receive the error message?
Did you find/adjust the mic privacy settings?

Ok now I have the second laptop running I am receiving signals at about 20 - 23 db.
wsjt-x seems to be doing the cat connection. But when I try tx or tune buttons it keys the rig but there doesn’t seem to be output.

Try the troubleshooting technique with the regular headphones in Digirig’s audio socket to confirm there is audio output. More on that in the troubleshooting guide.

OK I got audio output. I’ll look at the troubleshooting guide.
Thank You


Thanks for giving the progress report. Good luck.

73 Constrainted

OK so seems the digirig and wsjt-x are working, it’s been receiving signals and switching to tx but still no output from (ts)uDSX.
Try to do more troubleshooting.
At least I am able to have the software working look at hardware and setting om laptop.

1 Like

Taken care of sound settings on my laptop were not configured right.
I ordered the cablees for my G90 received them and got the G90 working.
I’ll have to do some time with (tr)uSDX .
But right now the digirig is working on my G90 making contacts. thanks for the time helpimg me.
73 Chuck

1 Like

Thanks for reporting the good progress!

73 Constrainted

Also have digirig working with my (tr)uSDX making contacts.
thanks for support.
Next step maybe winlink express with this set up