Problem triggering the PTT with Digirig 1.9 + Digirig cables + VARA FM

Windows 10 on Evolve Maestro III notebook with Digirig 1.9 + Baofeng UV5R (multiple) + Digirig cables (including USB). Latest Silabs driver.

I was getting a lot of old virtual COM ports hanging around on my system so I decided to remove all my unused ones using Device Manager. I did the same for USB devices. Up to this point, VARA FM + Digirig + Baofeng UV5R have been working great together.

After removing the COM ports - without deleting drivers, I couldn’t get VARA FM to make the radio transmit (COM port correct, Silicon Labs 210x driver installed correctly, PTT set to RTS). Plugging headphones into the audio port of the Digirig, I could hear the audio for the ping, but RTS did not seem to be triggering Tx.

I deleted the Silicon Labs 210x driver which is used for driving the Silicon Labs 2102 USB <–> UART chip on the digirig. Plugging in the digirig after that meant that there was no virtual COM port (it was COM7) - precisely what should happen.

I then reinstalled a fresh copy of the SiLabs driver. The COM port showed up as COM3. Firing up VARA FM - I could see audio coming in once I did the ‘open the soundcard menu’. I did a ping. Nothing. No Tx on the radio. I plugged headphones into the audio port of the digirig again and pinged - definitely an audio signal on the right side (as opposed to the left). This is correct.

I’ve written some software to connect to the port and try to turn RTS on for COM3. This should send a signal to the 2102 UART to put it into Tx mode. Nothing.

I removed the latest Silicon Labs driver and replaced it with an older version (6.7.6). Still no PTT.

I’ve tried this with two digirigs - both v1.9.

I’m convinced I’m doing something stupid. But for the life of me, I can’t figure out quite what it is. Any ideas?

Many thanks
Andrew - N1ACW

1 Like

Do you happen to have another computer to setup Digirig there and confirm that device/driver related shuffles may have caused the problem? You can also double check the cable and radio is still working by doing this PTT test:

1 Like

Yes, the first thing I did was to see if it was the cable, looked up the cable wiring on your website and had reinvented that test! :slight_smile: The radio did go into Tx when I connect the sleeve the nearest ring.

I’ve just tried another computer - this time a stock Windows 11 setup. VARA FM worked fine with the Digirig and Baofeng. So, it does sound like I’ve done something stupid. However, the Windows 10 laptop (that does not work still) looks to be identically configured. The exact same Silicon Labs driver is in place. I am sole user on both machines and a local administrator.

However, are there any possible registry entries that I should check? Are there any permissions issues otherwise?

I truly appreciate your help!


1 Like

I’m not experienced enough with windows internals to suggest the exact solution when something behaves outside of the norm like you described. My approach would be to try a series of increasingly drastic cleanup attempts from removing and reinstalling the device and drivers, to using devices cleanup/removal tools to windows reset if all else fails.

Please post what worked or what you learned in the process.

1 Like