Homebrew cable PTT issues

Hi all,

I am trying to get my Digirig (rev. 1.6) to work with a FTM-400XDE. The plan is to use VaraFM on 2m for Winlink.

I use the 10 to 6 pin DIN adapter from Yaesu and from there Digirig’s 6-pin DIN to TRS plug into the “Audio” connector of the Digirig device. Digirig is programmed (as per factory) to be able to PTT via the audio interface (COM+RTS) and not via CAT.

I can see both audio devices and the serial port (COM6) in the Windows device settings (running inside Parallels on a Macbook Pro). I have set these devices in VaraFM as soundcard and COM/RTS (COM6) for PTT. I have also renamed the audio devices in the sound settings and set the levels to the required values. I can hear the TRX audio coming from the FTM into the Digirig if I play it back via the Windows settings.

The problem: I am not getting the TRX to PTT (via Sound Card “Tune” or simply trying to connect in a VaraFM session). I have tried changing the FTM’s data speed, data band selections (using VFO B for all of this), switched off APRS etc. but the radio is not reacting at all.

In order to rule out problems with VaraFM I have also tried to set the rig to “none” in WSJT-X and selected RTS (COM6) as PTT method but nothing happened when I clicked “Test PTT”.

Does anyone have any info on how to set up the FTM-400 in order to work with the Digirig?

Thanks a lot and vy 73 de Leo (DL2COM)

In your case as well as in any other situation where PTT by RTS is not working as expected, the first thing I recommend is testing the cables by simulating Digirig’s PTT action. There is a quick and dirty method for that:

  1. plug the audio cable on the transceiver side
  2. unplug the other end of the cable on the Digirig’s side
  3. electrically connect sleeve to the nearest ring on the Digirig’s side


If radio keys up then the issue is on software/Digirig side. If radio doesn’t key up then the issue is with the cable or the connectivity between the cable and transceiver (incomplete insertion etc.).

PTT configuration and Troubleshooting:


Thanks Denis! I tried it and the radio does not key up when I short sleeve and ring. Note that the cable I got from your shop is TRS and not TRRS on the Digirig side. From there is goes into the Yaesu adapter and into the radio.


It sounds like you are using a cable that predates the PTT support. For hardware PTT support via audio socket you need Digirig 1.6 or later (check) and TRRS cables (nope?).

Ok it seems we have found the issue here. I will be in touch via email also about another cable I would like to order. Thanks again for your help!

1 Like

i created this c program to test the RTS on any digirig. Its not the best, because I am not a C programmer (or at least haven’t been one in over 30 years: did most of my work in pascal, python, perl, ruby and bash). But it works!

You just plug in everything to the radio and your computer.

just compile this $ gcc testserial.c -o testserial
and run like this: $ testserial /dev/ttyUSB0

the radio should be put into transmit mode.

to get out of this program just control-c

73, Jerry


#include <sys/ioctl.h>
#include <stdio.h>
#include <sys/types.h>
#include <termios.h>
#include <sys/ioctl.h>
#include <fcntl.h>
#include <stdlib.h>
#include <string.h>
#include <unistd.h>

int main(int argc, char *argv[])
int fd;
fd = open(argv[1],O_RDWR | O_NOCTTY );
int RTS_flag;


The below is on a Rev. 1.9 board.

After testing that the digirig to radio cable is good using K0TX testing recommendation above, and compiling and running the test script here, there doesn’t seem to be RTS PTT.

I have tested with android phone and USB-C to USB-C cable, using WoAD.

I have tested from a laptop with USB-A to USB-C cable, using test script.

In pulling the board from the enclosure, are any of the exposed test points useful in troubleshooting this issue? Either to jumper pins to try and force a state change, or, monitor pins for a state change when when RTS signal is introduced from software?

Any additional testing that can be run to test RTS, having Linux and Windows10 computers available?

TIA, Kyle

It would appear that you don’t have the digirig logic levels version. Im not sure but you may be able to make it that way by modifying the board.

Jerry, starting from Digirig 1.6 PTT by RTS is available in all configurations.
It is important to ensure the serial port is correctly configured if using serial CAT control or when programming the radio using the Digirig.

Roger that Denis

If you want to take a deeper dive into this, here’s few more tests:

red: will test everything from the connector to the radio
orange: will gest even deeper including the two switching transistors involved

If you are all tested out, I can just replace your Digirig.

Thanks a lot for the troubleshooting tips here!

My unit will PTT when I jumper the red or the orange, so it looks like the unit is behaving okay.

I setup Soundmodem on a Windows machine and got that working with Pinpoint APRS and with Winlink. So it looks like for whatever reason its a problem with my Android phone and WoAD only.

Kinda at a loss as the android phone sees the device when I plug it in. WoAD sees the device as Silicone Labs:CP2102N USB to UART Bridge Controller [/dev/bus/usb/002/004].

No matter what settings or re-installing the app I can’t get it to PTT. For reference my phone is a Pixel 6A XL that supports OTG. I’m using the factory Google USB-C to USB-C cable to attach to the Digirig.

Please post the relevant screen’s of the WoAD configuration and we can take a close look at that. WoAD’s author @VA7YAA in here too.

Happy to upload anything else that might be helpful, log snips, etc.

I really appreciate the help here. That the device this forum supports seems to be working but there is still an interest to help means a lot.

Not sure why people redact nodes but I followed the precedent.

When plugging in the Digirig I am choosing WoAD and the “just once” option.

I worked with WoAD creator Andrew on this issue. He discovered a bug in the 1.4.73 code. With the newest build 1.4.74 I am no longer having this issue and the Digirig is keying the radio as expected.

Full thread is here if interested.


I’m very happy to have this up and running. Thanks for the help, all.


1 Like

Thank you. This post helped a lot with an issue I’m sorting out. Now I know the problem is upstream of the transceiver cable.

1 Like