RPi4, Digirig, Baofeng UV5R -- No Transmit

Trying to set up FLDIGI on a RPi4 using a digirig and the black Baofeng cable. The current setup does not transmit. VOX is off on the UV5R.

Current soundcard setup:

Current PTT setup:

The two PTT devices available are

Neither choice makes a difference.

I have two Baofeng black cables. Have tried them both, pushed completely in, no joy. Microphone plugs in and works correctly.

Have made no changes to the Digirig itself other than to plug in the USB cable and the Baofeng black cable.

I’m clearly missing something… Help appreciated.

Thanks and thanks again!
Roland K7OJL

Roland K7OJL,

That’s frustrating, but there are some ways forward.

When you press the INITIALIZE button in the Rig Control/Hardware PTT configuration window, success gives no response, and failure generates a message. What do you see?

/dev/ttyUSB0 should have file permissions which allow the- user running fldigi to read and write. What are those file permissions on /dev/ttyUSB0?

73 Constrainted

1 Like

Thanks for the questions. When I click ‘Initialize’, no error message comes up.
crw-rw---- 1 root dialout 188, 0 Apr 26 07:34 ttyUSB0

User Pi is a member of dialout


1 Like

OK, thanks for trying those. No solution yet. Next, consider trying a PTT test, as explained here:

Even though you cable is not a homebrew, this method should simulate the Digirig’s PTT action. Good luck.

73 Constrainted

PTT does work by shorting the sleeve to the nearest ring. I’ve put the radio into VOX mode and that is working until I figure out how to get RTS to work. Thanks!

Select “use separate serial port ptt”, ensure “use RTS” remains checked. Click initialize. Save.

Try selecting the other USB device available in that dropdown menu. Anytime something is changed in that manu, click initialize and save.

Sometimes after saving, I also have to close fldigi and reopen it again.

Don’t forget to turn your vox off.

1 Like

After you get the PTT issue resolved, there’s still a lot more to be done.

Go to your terminal window and type alsamixer. Select digirig in the f6 menu. Select f5 to look at all settings. Move sliders so that everything is as close to zero db as possible. Select auto gain control and click m to mute it. Close alsamixer and type sudo alsactl store. Then exit terminal.

Turn squelch on your radio to zero and tune the volume knob until the colored diamond indicator at the bottom of the FLDIGI screen turns yellow, then back it down until it just barely turns solidly green. The setting at the bottom that currently says “-12” is an attenuator that can be increased to zero.

Phew! Now you should be in business.

1 Like

Make sure the cable is inserted very well. Really give it a hard push after your think it’s in. Many of the Baofeng radios have questionable quality control at the K1 connector. It feels like I’m going to break some of mine before they start working correctly.