Trouble (and solution!) connecting Digirig to a Raspberry Pi

I ran into some trouble using Digirig with my Raspberry Pi that turned out to be unrelated to the Digirig itself. I thought I’d share what I learned here in case it’s helpful to others.

I used KM4ACK’s excellent Build a Pi script to set up a Raspberry Pi for radio tasks. I made some homebrew cables, after carefully studying the Digirig schematic and adding some important modifications to my old Icom IC-751A.

Before connecting the Digirig to the transceiver, I set up the rig in fldigi, making sure to set PTT via RTS. Luckily, I had it hooked to a dummy load, because when I connected the radio to the Digirig, it immediately switched to transmitting. What’s more, none of the software could communicate with the serial port.

I was pretty sure I had screwed up the cable builds, but I triple-checked everything and couldn’t figure out what could be wrong. A little research suggested that there might be a process in the Pi commandeering the serial port and preventing radio software from interacting with it. The usual suspect in Ubuntu-land is brltty, but my Pi didn’t have that.

Turns out there’s a GPS daemon (gpsd) that can do the same thing. And sure enough, my Pi had it enabled! I found the solution on /r/digirig, crediting Rocco (WQ1Q) for discovering the solution.

Edit the gpsd config (/etc/default/gpsd) to prevent it from automatically taking control of USB devices:

# Automatically hot add/remove USB GPS devices via gpsdctl

On my Pi, USBAUTO had been set to true. I’m pretty sure this was done by the Build a Pi script, rather than being a default/out-of-the-box Raspberry Pi setting. I remember something about enabling GPS from the Build a Pi setup, but I never would have thought that would cause a problem with the Digirig’s serial port.

Hope this helps someone!


Thank you ! I was struggling with this for the whole day and you saved me from just giving up.
-Kevin (KK4YEL)

1 Like