Xiegu G90 Transceiver not responding! Check serial (COM) port

I got my Digirig a few days ago and I’m trying to get it setup with FLrig because I want to use JS8Call and it need FLrig. I have a Windows 10 Laptop. I don’t know the Digirig revision number but if you tell me how to get that I will post it here. I also have the 1.7903b firmware installed on the radio. I believe this is the newest version of FLrig.

I plugged in the Digirig and Windows saw it like it should. I downloaded and installed the drivers for it like the Digirig instructions say to. It shows up on COM4. I changed the bits per second to 19200 and stop bits to 2 like everyone says to. I have the cables connected from the Digirig to tge G90. I setup FLrig for the G90 and COM4, same baud and stop bits setting. When I hit Init I get the “Transceiver not responding! Check serial (COM) port connection. Open menu…”

Below is a screenshot that should show everything. I’ve tried all the different song and dances (setting up FLrig first with the radio off, close FLrig, turn radio on then start FLrig) and followed every YouTube video I can find out there but I’m not getting past this. I’m at a loss.

You can check revision and configuration by looking at the back side of the PCB. For CAT control of G90 you want logic levels configuration.

For making sure the serial port and cable are working you can use a loopback test:

My first suspicion would be the software. There were some versions of FlRig that didn’t work right. For troubleshooting also try direct configuration with WSJT-X or omnirig.

As far as the revision, do you mean open up the Digirig and look on the circuit board? I don’t understand what “logic levels configuration” is but I do want CAT control.

I did the loopback test and got an interesting result. You first typed before you shorted the cable so I did that expecting nothing but it just showed what I typed. I unplugged the cable from the Digirig (kept the USB in) and typed again and it still showed what I typed. I’m assuming that shouldn’t occur?

Yes, the revision info and the configuration is on the back side of the PCB. Getting to that involves removing 4 Phillips screws on one of the sides of the interface.
You can share the picture of the back side of the PCB here and I’ll confirm the info.

Re. loopback without short: either the terminal software has the “echo” feature turned on or your Digirig is configured for CI-V which could be the reason it doesn’t talk to G90.

Looks like Rev 1.9. How do I tell the configuration? I’m glad to know it was made on earth!

I am using Putty just like in the video. I don’t see any echo option where you choose Serial and the com port. Is there an echo option somewhere else?

Thank you for the help by the way!

I found an echo option which was on, I turned it off but it still does the same thing. I don’t even have the serial or audio cables plugged in to the Digirig and whatever I type into the Putty terminal is showing on the screen.

That solder on the board doesn’t look healthy and likely connects TX/RX lines.
Will you be able to remove it or would you prefer your Digirig replaced?

I didn’t notice that. Yea it looks like it is. I’m not good at unsoldering small things like that. I can send you back this one in exchange for a replacement.

RR. Arrangements in PM.