Digirig not getting Mic input on Win 10

so I got 2 Digirig modules imported from the USA to India.

now that I have started with the testing of one device it is getting detected by the Windows PC in device manager as stated.

but when I try to go according the the Digirig Video on Youtube (https://www.youtube.com/watch?v=wBFFI-31tU0&t=404s) to troubleshoot… my Input does not show any activity.

I tuned the local FM station to check the audio input but alas had no luck.

how can this be solved?


Do you encounter similar problem with the second unit you received?

Hey Siddharth,

The issue of Windows 10/11 audio setup can be tricky as there are many things to address. To avoid listing them all here check out the 12/2023 post by N1SPW at the top of the following thread:

N1SPW’s website has has some EXCELLENT step by step setup instructions for a Digirig under both Windows 10 & 11. He covers everything including some settings that are easy to miss.

  • Dave, N1DAE

so everything is going as per the documents and videos.

but when I check the input in the SOUND option of the window I can listen to the Handy audio through the laptop when I check the (Tick) box under the Recording tab where it says “Listen to the device”

Once I remove the check mark on the “Listen to the device” the status bar does not show any output levels as shown in the video.

I tried both the Digirig devices. Same issue with both!

If you get audio input with “listen” checkbox checked then Digirig’s input is working.
Please verify that none of Digirig devices are assigned as system or communication defaults, you explicitly select Digirig audio components in your ham radio software and that windows privacy settings don’t prevent apps from accessing the microphone.


Im having a different and interesting issue on mine.

The sound mixer shows the mic and speaker for the digi891 HOWEVER…no com port has been assigned to it.

Missing COM port can be frustrating.

A missing COM port is a very common issue for Digirig soundcard devices. Usually can be fixed by installing the USB-UART driver.

See Getting Started with Digirig Mobile – digirig and pay close attention to the USB-UART driver information.

This thread is not about the DR-891. For issues with the DR-891 cabling, see topics tagged:



73 Constrainted

Ty for the reply but I have already done that.

the regular digiri works just fine and shows up.

the new digir891 does not.

however, I went to my Ubuntu machine and tried things and it will not Rx a signal.

I do not believe this digir891 is functioning correctly.

OK, let’s discuss in a new thread, COM port missing for DR-891

73 Constrainted