IC-718 and CAT control

Straight out the box today. Setup all the cables as directed in the previous post. Can receive but CAT/CIV fails. Tried in both HDR and WSJT-X. All the configurations, including clean boots.

The CAT does not work. I left the audio plug in and connected the sub. Pc sees it as audio. I config the audio.

Wsjtx receives and decodes the audio. But it won’t transmit.

I swapped out the serial cable which was plugged in the CIV plug. Replaced it with a usb-civ cable that worked before. It controls the cat. Even returns a good test in wsjt. Your cable fails the wsjt cat test.

But it doesn’t seem to transmit with either cable. Used the rst option.

That sounds frustrating. I do not own your radio, but I don’t want your question to go unanswered. There is a guide Troubleshooting Digital Modes – digirig which gives a step-by-step approach to isolate and solve each problem.

There is a thread discussing IC-718:

Thanks for posting the photos of your setup. Is your Digirig configured for CI-V output rather than logic or RS-232 levels? You can see more discussions about IC-718 here:


73 Constrainted

Let’s get PTT working before dealing with CI-V.
Please make sure Digirig’s COM port is detected and has a driver. The COM port will appear/disappear in device manager when you plug/unplug Digirig.

In WSJT-X set rig to “none” (temporarily) and set PTT to RTS of Digirig’s COM port. This should get you the successful “Test PTT”. Button turns red, radio keys up.

If not, then see how PTT can be simulated for troubleshooting purposes:

I went through the youtube videos and determined that

  1. Sound is working and configured.

  2. Serial cable or digirig serial device seems to be the problem.

2a - I downloaded and tested with putty.
2b - using another usb-civ cable, I got the feedback loop to complete.
2c - using the green wrapped serial cable, connected through the digirig, there is NO connected loop. While the tips are slightly different (see photo below), I tested the digi serial cable from tip-bands 1/2 none connected.

  1. Is there a way to further test the serial cable or the digirig itself?

digi serial cables are the two gold ones

I have to laugh because I’m watching your videos in real time and I sitting here trying to figure out how I loaded a youtube video into this forum.

be right back with results


Audio receive is great

Let’s start without CAT control in the way:


Can you confirm that COM17 belongs to Digirig? Please share the screenshot with that port visible in device manager.

Com17 is Digi

With “None” selected PTT is succesful

Great, now back to CI-V.
With your Digirig’s packaging rocking Amazon sticker I’m thinking it’s still in the default configuration. At the time of writing non-default Digirigs are not sold on Amazon.

Here’s info on configuring serial port for CI-V:

You have WAY more faith in me than I do! LOL Here’s my board, is soldering the only option for an IC 718 CIV?

If so, will I need a second DigiRig for my other radios? I expected to get the correct cables (TYT TH-9000, Yaesu FT50R, probably some 10M rig later for POTA)

You can get a pre-configured Digirig from the online store. Select “CI-V” option.

You can use the one you already have with your other radios including those you listed.

Best option is buy a configured one! Ordering it now

Your help is AWESOME - thanks!

Much appreciated. Your order ships today.

I had this exact same issue with my Win 11, IC-7851 setup. Digirig support pointed me to YouTube videos. After nearly two weeks of banging away at the problem, including seeking advice from other Digirig users, I gave up and returned it.

Like you I could receive but could never get the radio to key up via CAT. Not sure about others but I would have liked some specific information about hooking this up to an Icom radio…I seriously have low patience when it comes to a “customer service” agent who’s simply there to point you to YouTube vs. actually trying to help you. Why bother paying a customer service agent if all they do is point you to YT videos? (Rhetoric)

P.S. According to the plastic packaging I did have one that was allegedly designed for the CI-V exchange.

@Dave Are you ready to try again?

73 Constrainted