NO PTT pi/direwolf/digirig/kenwood th-f6

Following David’s instructions:

I will say I am successfully using a signallink. I tried getting digirig going for 2 evenings. I swapped out for the signallink tonight. And it just worked.
Digirig is ver 1.9. Direwolf is a compiled off the dev branch.

Using the digirig. Cable is plugged into the audio port.
I can receive, I can send IFF I press PTT manually.

ADEVICE plughw:1,0
MODEM 1200
#PTT /dev/ttyUSB0 RTS
#PTT CM108 /dev/ttyUSB0
#PTT CM108 /dev/hidraw0

Anyone have any hints?

PTT /dev/ttyUSB0 RTS sounds like a correct choice assuming that USB0 is Digirig’s COM port.

Note that PTT method used by Digirig is different from that used by signalink, that’s why the configuration adjustment if needed if you are swapping between the two.

For other direwolf related posts please visit: Topics tagged software-direwolf

Those commented out PTT lined are ones I’ve tried.
I followed various articles and looked the udev rules installed by digirig. Seems the hidraw0 is the digirig device. ttyUSB0 is linked to /dev/gps.

There were reports of gpsd messing with Digirig thinking that it found a compatible hardware. This could be the reason you see that the port is associated with gps, while in fact it can still be Digirig’s port. See if these help:

1 Like

Spend time with a friend trying to debug. I thought I had a new enough digirig. Aquired it about 2 years ago.

Board version 1.3

Would be nice if there were external labels.

Board version and type ( defalt, rs-232,…)

I ordered a new one. Will test when I get it.

1 Like

That explains it. Please keep us posted.