Readout of FTM-6000 with YAESU miniDin10 &CAT cable gives 'Format error'

Connected green plug of YAESU DATA&CAT cable to serial socket of digirig. Started ADMS-13 SW and tried to readout FTM-6000. TRX goes into mode ‘CLN Tx’ as described. When RX is started in ADMS-13 and then the DIAL button on the TRX is pressed, ADMS-13 immediately says ‘Format Error’. On the TRX, the message ‘SND.ERR’ appears.
The COM port on the PC is recognized properly and it is correctly set in ADMS-13. Tried several baud rates and with/without HW-handshake. No luck. Has anybody been successful reading out data from FTM-6000 or any other similar YAESU rig like FTM-400 etc.? Or does ADMS-x only work with yaesu cables?
Any hints?
Martin HB9AUR

1 Like

The info I’m finding on Yaesu’s CT-163 cable, specifically the fact that it uses a classic RS-232 connector without any active components, suggests that the serial port in FTM-6000 may be using RS-232 levels


If your Digirig is in default configuration, you can try re-configuring it.

1 Like

You guessed correctly! In fact, I should have tested the voltage on the RIG_TXD. It is -6 V. So definitely using traditional RS-232 levels.
All working fine now, proving the versatility of your product!
Martin HB9AUR

1 Like

OK, I am lost. I use the DR on the 6000 for Winlink. Is the poster using the DR to program the radio?

Yes, I use digirig mobile also for programming the radio, not only for WINLINK and VARA FM. Why are you lost?
Martin HB9AUR

“Lost” in the sense of using DG with RS products. Did not know that could be done

So I successfully modded my digirig to the RS-232 configuration mod as the first example in the video. I believe that was done correctly. I then am using the green connector plug into the serial plug on the digirig. I run the Yaesu software. I have selected the only com port that shows up and it is the digirig I believe. I follow the instructions of the Yaesu software, but when I push the knob with clone TX selected, I get “format error” from the software and SND.ERR from the radio. Any ideas?

I see that you mentioned baud rate. Any suggestion on the baud rate and/or settings that you found success with?

In ADMS-13, the only setting is the selection of the COM port. The SW sets Baudrate and other possible settings by itself. All driver configurations seem to be overridden by the SW.
Did you check with an Ohm-meter if the traces for the mod were cut correctly? I had to work pretty hard to open them.

I’ll go back in. I am pretty sure I got it correct but I’ll try again. I’ll let you know :slight_smile:
de VE7KZ

No joy. Immediate “format error” on ADMS-13 and SND.ERR on FTM6000. Hmmm. Perhaps I will have to buy a programming cable. They are so expensive. I really thought that my digirig and the digirig cable I bought would have been able to program.

Best regards,

If you need to check the results of your soldering handiwork, here’s how you you can a loopback test of the serial port:

Thank you for your response, Denis!
I will try the loop back tomorrow. Today, I checked the continuity very carefully as per the video of switching to RS-232. I did get what seemed like what was going to be a read. It ever so briefly looked like it started to read, and then went to error. After that it went to error immediately. During my testing, the channels that I had already stored in the radio got wiped. Radio seems to be okay. Hopefully no “magic smoke” got released from my DigiRig. :-O.

I’ll let you tomorrow.
Best Regards,

So this is my loopback test:

There is certainly something wrong.

Movie of results:

Best Regards,

That doesn’t look right in the terminal.
Here’s the cable pinout:

based on that I would say that your loopback connection is correct.
Let’s look at the soldering. Can you post a good resolution picture of the solder jumper connections?

Also is anything is getting hot on the board?

Here is the photo. Hope it has enough resolution

This area gets slightly warm when attempting loop back test:

Here is a video with some resistance values of the DigiRig not plug in to anything:
Currently as of me posting this post, the video is still “processing”.

These should have no short connection:


You hit most of them in the video, but not the middle one.

MOTHER OF GOD and ALL THINGS HOLY!!! I was getting some spurious fluctuations between open and some times ~700 ohms fluctuating. I cleaned between pads with razor knife where you indicated it should be open… and loop back now works!!! FTM-9000R will be next test. I’ll report again! :slight_smile:

1 Like

So the software goes into “Receiving Mode” (now at last) and just waits there saying “receiving”. When I press the Radio Knob to start “CLN TX”, the radio indicates SND.WAT for about 5 seconds and then reports “SND.ERR”. The software then returns a “time out error”. FML. LOL.

WOOT!!! WOOT!! WOOT!! It works!! It’s ALIVE!! ALIVE I tell you! READ and WRITE!

With your help invaluable help, after I squared away the solder pads, and a successful loop-back test the DigiRig itself worked fantastically. The problem was, I think, with incorrect drivers. I had been messing around with VARA FM and a Raspberry Pi and somehow got some version of CP230X (Not the VCP) drivers installed on my windows machine. After uninstalling and manually installing CP230X VCP drivers I can both Read and Write to the radio!!

Happy Days!

1 Like