Which DigiRig for (tr)uSDX?

Which model of DigiRig works best with the (tr)uSDX transceiver?


Without the CAT control involved, any configuration will work for your (tr)uSDX. I’d go with default (logic levels) unless you have a reason to select another configuration.

Digirig 1.9 with cables by K0TX works for me. TruSDX firmware 2.00i. I am not using CAT control.

73 Constrainted

CAT on truSDX seems to be discussed frequently on their forum. For instance:


Settings for CAT control are discussed here:


73 Constrainted

1 Like

Which cable is that?

I use this cable set from K0TX/Digirig:

uSDX Cable for Digirig Mobile – digirig

but I do not use CAT control.

73 Constrainted

What do you use for PTT If your not using CAT are using VOX

Not CAT, not VOX, I use COM port RTS line to pull PTT with fldigi, soundmodem, Vara FM, Vara HF. wsjt-x.

73 Constrainted

I am using Omni-rig. Vara HF are you doing Winlink express?

Chuck 73

I’m trying to do Winlink with the (tr)uSDX, Win11, DigiRig and VARA HF but cannot get a successful connection. I’ll spool through 40m Auto-connect fine and can see my signal on webSDRs but gateways will not connect. I have the (tr)uSDX Volume set to 8, which is 1/2-2/3 on the VU Meter and Playback/Record set to 50%. I’ve run with VARA HF Drive Level at every level. I guess I’ll have to try different Playback/Record settings. The 40m EFHW antenna works great on 40m for FT8/JS8CALL. What are your settings for Winlink?


Yes, Winlink express.

That’s great you can verify your radio’s output on websdr.

The dial frequency of the truSDX must be aligned, Menu 8.3 Ref freq. If I have trouble connecting to a gateway, or do not hear any Vara traffic on the frequency, I check the Winlink express Message Viewer to make certain the gateway has passed traffic recently. Sometimes the gateway is down.

73 Constrainted

I having trouble using digirig mobile I not receiving any signals and when I transmit my antenna tuner doesn’t show any power out. I tried to check sound system setting.
I am going to try another Laptop to see if it works .
Ok on Winlink express. That will be next once I get the wsjt-x functioning proper.
Thanks for your help

Thanks for posting. I am not sure if the error prevents you from posting a screencapture of:

File → Setting → Audio →

which may look like:

73 Constrainted

OK. Thanks for posting.

Do these settings look correct to you? PnP may not always label devices sensibly. Is “digirig (FlexRadio Systems DAX audio)” a digirig output or a FlexRadio output, or a rewritten label? Is the USB PnP microphone a Digirig device or label left over from a previous USB device installed on the computer? I’m not sure what to tell you here. Sometimes my sound devices for my USB headset remain in the settings menu after the device is unplugged.

73 Constrainted

The PnP label is what I found using device manager,
and I rewritten the label as digirig.
I thinking it maybe an RF problem from another discussion on this forum.
I have ordered a new shorter usb 3 cable for between my computer and (tr)usdx.

“Error in Sound Input” at the program launch can be caused by the mic privacy settings in Windows.
If this only happens during the transmit then it’s likely RFI.
Please see the troubleshooting guide for solutions to both scenarios.

I ordered the shortened cable with the chokes and at that time I ordered the cables for the G90 .
I received them and worked thru the process and seems the sound settings on the laptop was the biggest problem.
With the help of some You tube videos my G90 is working withe the new cables and I am making contacts of FT8
Thanks for all the help
73 Chuck

1 Like