Xiegu G90+digirig Mobile+flrig+WSJT-X = No Output at Radio

I’ve gotten to the end of the “Things I know to try list” and my set-up is responding differently then the YouTube videos show. Everything seem to work in WSJT-X using flrig (same result when “connected” directly in WSJT-X) Test CAT turns green, Test PTT turn red and radio light turns red. The problem is when PTT is turns red, the G90 goes into transmit mode, but the power reading on the display is 0.0W and the ALC is at 100 and is not affected by any changes I’ve tried. My last hope is changing out the USB/USB-C cable which hopefully come in tomorrow. Any ideas on things I can try until then?




Recording11Jan24
Sound11Jan24

That sounds frustrating! If you want to try something while you wait, check WSJT-x File → Settings → Audio to make sure the audio devices are correct. If there is PTT but no power out, maybe there is no audio.

Also, I usually reseat all physical connections followed by restarting all software when things aren’t working.

73 Constrainted

It is indeed. I’m pretty sure I’ve tried every combination Audio. I’ve attached my current settings. Just let me know if something jumps out to you.

One other piece is I’m working with a very compromised antenna current. I’m trapped in an office until I can get a hole in this wall. So even though the antenna tunes it ain’t much. I wouldn’t think this would impact this part of the puzzle though.

The audio tab looks good to me. Do you get enough receive signal to decode FT8/FT4 etc?

73 Constrainted

I’ve gotten a couple of random signals (see attached) but nothing consistent.

I can’t imagine the antenna impacting the no power out from the radio though.

Got the new digirig branded USB/USB-C cable in. Same problem as listen above.



FT8_08Jan24 (1)

If you get any functionality (e.g. any serial comms or any audio) then the USB side of things is working fine.

With the latest G90 firmware the mode should be set to U-D (upper side band digital) when operating digital modes. See this post for additional info:

1 Like

Thank you for your help. I tried following that video (it’s where I got the USB mode from). I have since changed it to U-D and received a signal. I’ll try these setting for awhile.
I went ahead and got the digirig USB/USB-C cable because on other post it seems that was the problem. I’ll keep plugging away but think I might be getting closer.
Thanks again!

2 Likes

Did you ever get it to transmit… I have exactly the same problem. Zero power out on transmit.

I know it’s a computer issue because it works perfectly on a Win10 system but not on my Win11 laptop.

Steve

Yes it has been working well since things squared away. I had a cable issue and another issue with settings. I think I have a G90 document showing typical setting.
If the digirig was working with you G90 and now with new PC isn’t. Triple check all your sound settings on this computer.

Thanks I have checked PC settings. They match every checklist / video I can find.

Laptop worked before upgrading to Win11… hasn’t worked right since.

I think a new laptop might be in order… lol.

73

Steve

N4RAF

Grid: FM19fe

https://www.qrz.com/db/N4RAF

Steve, do you get audio output from Digirig to the headphones as shown here:

Hey Steve,

Here’s the settings that I mentioned. And definitely take Denis’ advice, he helped me get up and running.

But I think you’re probably right, there’s probably a legacy audio device that you haven’t found the right Win11 driver for. Trying to hunt those down can be so frustrating. I’d find another laptop. That’s one reason I keep fighting myself not to update any computers that are playing nice with my radios.

Hang in there, you’ll be back on the air soon!

(Attachment G90 Settings with FT8.docx is missing)

Here’s those settings. It didn’t like *.doc file, here’s the .pdf.

G90 Settings with FT8.pdf (98.6 KB)

I’ve been fighting the same problem and think I found the solution - for me at least.

I’m using the flrig interface and there is a PWR slider on flrig. The G90 output power is controlled by that slider, not the one on WSJT. Made a handful of contacts this AM on 20 meter FT8.

Thanks for the info. I’ve made several changes along the way and now can control my G90 from WSJT but glad you found another work around