Receive but can’t transmit

Ft8cn on Rfinder android tablet to kx2 through digilink

It almost works. It receives and decodes beautifully. Without using digirig, it does the transmission cycle giving a solid 15 second transmission on the selected portion of the frequency. So, VOX will work

Digigig is USB c to USB c on cat. Audio is digirig out split to headphones and microphone on the kx2. Cables are correct and working

The audio reaching the radio is not the transmission cycle. It is a quick blip followed by nothing for the cycle. I tested this with a separate speaker So, it’s not the radio

That leaves Ft8cn, the tablet USB and the digirig

Ft8cn seems to create the correct signal when not connected. So, something is happening when the digirig system is connected

The digital ct connection seems to work. For example, the program can be used to change the radio frequency and the cycles appear to be correct. The transmit light goes on when it should. But there is no sign of a signal to be transmitted

I noticed enquires about other radios with a similar issue so I am thinking that there is an issue that is not radio or tablet specific

Can anybody help?

You can check if there is audio output from Digirig by plugging regular headphones into Digirig’s audio socket. More info on this in the troubleshooting guide:

I did that, but using a speaker. As indicated, I get a very short bleeping sound then nothing for the cycle

I have gone through all of the troubleshooting recommendations. None are right on point. None have led me nearer to a solution

All my obversations lead down to this:

All components individually work

It’s not the radio

So, I look to the difference between my setup and that of those who have working systems

The digital CAT works. The audio is an analog system. That might be the difference

The transmit output of ft8cn changes character when connected to digirig through usb. I have tried it with USB audio routing enabled and disabled. No difference

Is it in the tablet and it’s USB?

Is it in the ft8cn settings? Or code?

Is it in the digirig?

I am stuck

This is a picture of what pops up when opening ft8cn. It accords with what the troubleshooting guide suggests should be in a pc. But my reading suggests that this is not consistent with an Android tablet’s USB

Can this be the problem?

I forgot to thank you for your earlier prompt response. My apologies

This is not USB, none of the Digirig components would be recognized by the computer if there’s a USB problem

This isn’t Digirig’s audio, otherwise you wouldn’t hear anything via the headphones.

Try ruling out transceiver settings by running FT8 from PC on the same Digirig+cables+radio.
That will leave you with just system/software settings.

Thanks for your reply.

I can’t test on a computer right now

I reinstalled FT8cn and put nothing in the settings except a call sign. Connected to nothing it goes through the routine to receive, and goes to transmit on cue. I interrupt the transmit cycle by plugging in the Digirig but without the radio connected.

It interrupts the transmission, asks for confirmation of the connection and then says rig connection confirmed. Again, it cannot know the type of radio because I didn’t input that. It can only know that something was connected to the USB

It carries on with the remainder of the transmission cycle but there is no audio or spectrum. The picture was a screenshot taken at the moment of plugging the digirig into the USB of the tablet.

So, somewhere between the program and the digirig the correct transmission communication is lost. It doesn’t seem to be in the usualFT8cn settings, because I didn’t set anything and got exactly the same result as I get when the KX2 settings are input and the radio connected. I checked the FT8cn settings before and after attaching the USB cable and there is no change

I am stuck

This must be due to my lack of familiarity with FT8cn, but I’m having hard time interpreting the results of your experiment with unconfigured software and hot-plugging the interface.

If you don’t have access to a PC, is there any other software you can try on that that tablet? Here are some options:

There is a confirmation of FT8cn working with Digirig in this post:

I had the exact same problem when trying to link a smartphone to my Yaesu. Perfect receive, would trip the rig to transmit on transmit cycles, but would send nothing for 15 secs before reverting to receive.

The answer, it turns out, is that there is nothing wrong with anything (!). The problem lies in that the developers at Google have chosen to remove audio from the micro-USB / USB-c connector from Android 11 / 12 onward. Your hardware and mine were working fine within their specs, except the specs had been changed. In earlier versions of Android, you can go into Developer Mode and ensure audio is available at said connector on your device BUT BEWARE. Most smartphone / tablet sellers do tweak the version of Android they put out. Samsung famously loads their devices with a load of their own programs, which you can’t uninstall. Some disable audio at the USB connector.

I solved the issue by going down another route altogether, using purely audio signals. I ignored the USB connector, and instead used the 3.5mm jack on my 'phone, linking the 'phone’s speaker output to my rig’s mic, and my rig’s headphone output to my smartphone’s mic. Not my invention, I did exactly what is stated here…

and it worked supremely well.

CAVEATS - 1. There is no longer a digital link between your rig and the tablet/smartphone. Changing the frequency on one will not change the frequency on the other, so for the purposes of the auto-generated log if nothing else, you have to tell both devices yourself.

  1. Most tablets do not have a socket for an external mic. You may need to use an external soundcard. Or you could use a smartphone…

ADVANTAGE - No software downloads or installs, the same exceedingly simple and low-cost interface will work across a whole host of devices.

As you can imagine I cannot offer any guarantees that this will work or that you will not overload the inputs to either device using the audio route. You do this at your own risk. All I can tell you is mine works supremely well (PS I put mine in a nice little box)

I am still looking for the solution. I get the attached pop up on initially starting the program. I always confirm but wonder if it’s correct. Any thoughts?

I am aware of the limitation on the usb settings. With some fooling around I have audio on the USB. YouTube works for example

With the digirig connected I get a microsecond of audio then it cuts out

I have a headphone jack on the android device so I bought a splitter cable to try what you described. No luck

I’m out of ideas