Yaesu VX 6R settings for packet winlink

I have a Yaesu VX 6R with a Digirig and having trouble getting Packet Winlink to work. I’m connecting with the local node but not getting an answer back. I’m thinking maybe it’s a setting in the radio itself. I think I have the settings on Winlink and the sound card figured out. If anyone has the set up with any suggestions I would appreciate it. Thanks. Mike KD9BKU

Please check out this discussion and let me know if the same solution doesn’t work in your case:

Thanks for the quick response Denis, I’ll try this out and get back to you

1 Like

Still no luck, I adjusted the volume to every level and wont connect, I also have a Baofeng having the same issue, There was a short time I could get the baofeng and the local node to connect but it still wouldn’t send or receive mail. Now I can’t get the digipeater to respond at all with either radio.

Can you try direct link between the two stations that are next to each other?
This way you’ll rule out RF link issues.

Sorry, not sure I understand what that means? Between which 2 stations? Thanks

This is just a troubleshooting idea. Because qualify of RF link can be a decisive factor in establishing the link, removing this factor allows you to exclusively focus on other areas of the setup (such as audio levels).

Of the two stations, one would be the winlink station you are setting up, another is the station you are trying to connect. This could be a digipeater, your friend’s winlink station or an additional station that you setup at home.

I am wondering if there is a menu setting in my radio that is incorrect. I have tried different antenna set ups, and volume setting. I have squelch off and seem to get good reading on the sound modem screen. I am less than 3 miles from the digipeater station so I think I can hit it easily.

Squelch and volume knob are the only controls I used on the HT side for digital modes with other models. It’s unlikely VX-6R needs anything special. For good measure did a quick googling for the relevant info and didn’t see any other settings mentioned.

You can post a question in comments to Gaston’s video on this topic:

I spent quite some time trying to get VX-6 and VX-7 to work with Winlink and sound modem.

I will try to write a document sometime soon but for now these were my mistakes/problems/road blocks:

1- If you use Soundmodem in setting-> Devices check: - Single channel output

  • uncheck AGWPE
  • check KISS server with port 8100
  • uncheck Dual PTT

in setting-> modem setting:
-Modem type A choose: AFSK AX.25 1200bd
-TX delay: 500
-check Kiss Optimization

and in the main page of the soundmodem choose 1700 as the centre and check Hold pointers and I did lower the thereshold to the second line.

as for the Winlink I did following:
-Packet Winlink
and Setting:

  • Packet TNC type: Kiss
  • Packet TNC Model: ACKMODE
  • Serial Port: TCP
    -IP: Port: 8100
  • Automatically lunch soundModem and address of your soundmodem
  • Enable IPOII

of cource you need to play with your computer and VX-6 volume, but if these did not help you need one more layer of troubleshooting which is mainly fine tuning the volume.

PS make sure your repeater is not duplex.

1 Like

Thanks for all the info and tips. I finally have it working after weeks of trials.
The last step for me was the volume, I have it set on first click from off, that’s the opposite from what I read and heard on other sites. They all said full blast. Low volume gives me a nice green waterfall and connects quickly.


VA7AYG - I have two Yaesu VX-6R HTs. I’m trying to use Digirig and Soundmodem with APRS and Winlink on my laptop. I’ve tried your settings and pretty much every other combination and I can’t get Soundmodem to transmit (activate PTT) on either of my VX-6Rs. I even tried the Calibration test in soundmodem and I hear it through the listen option in the Digirig recording device settings but the Yaesu is not triggered to transmit. Note that I also have a Baofeng UV-82 and the digirig/soundmodem setup works (transmits) no problem with the Baofeng. I purchased the Yaesu VX-6R and Baofeng cables from Digirig. Any ideas why it works with the Baofeng and not the Yeasu? Are there any special settings you did on the VX-6R to get it to work? Do you think my Digirig Yaesu cable VX-6R is bad? Do you have a suggestion for a different modem software to use with my Yaesu radios if Soundmodem is no good? I know. Lots of questions. Any help will be greatly appreciated. Thank you.

Maybe a partial cable contact. Try the PTT test described here:

Thank you for your very quick reply. I tested as described using the Yaesu cable I bought from you and the VX-6R does key up (transmit) when I touch the sleeve to the nearest ring. Also, as an FYI, the Mobilinkd TNC3 I own does key up the Yeasu no problem. So it appears this test indicates the cable is good and maybe the problem is with the digirig or something missed in the soundmodem configuration (though I’ve used the config described above and about every permutation). I have digirig firmware version 1.6 (at least that’s what’s written on a piece of tape on the digirig package). Any other ideas? Thanks

Yes, the cable and connection are good. Let’s look at the screenshot of the software configuration pertaining to PTT. Digirig uses RTS signal of the serial port to trigger PTT.

When using the Calibration option in soundmodem to send a test tone with the Yaesu VX-6R connected to the Digirig PTT does not happen but connecting my Baofeng with the exact same configuration the Calibration test tone does trigger PTT on the Baofeng. I currently have the level set to 20 on the Playback and Recording Digirig devices.

The documentation for the Mobilinkd TNC3 has this bit of info for configuring the output:

"Modern ham radios use two different signaling methods for the Push-to-
Talk (PTT) signal, which causes the radio to transmit.

Most base stations, mobile rigs (anything that uses a MiniDIN-6 data
connector) and any radios with a Kenwood-style connector use a
separate PTT line to trigger PTT. This form of PTT signaling is called
“simplex” since there is one signal on the line.

Many HTs (Yaesu, Icom, Alinco and others) use the Mic+ line for both
audio and PTT signaling. This form of PTT signaling is called
“multiplex” since there are multiple signals on the same line."

I suppose it possible the soundmodem software doesn’t know how to do the multiplex signal for the Yaesu and people who say they are using soundmodem with their Yaesu VX-6R are lying. There is no option in soundmodem to switch between simplex and multiplex.

Sorry I am late, for me the problem was the o-ring that prevented the plug to go all the way through the HT. Please can you check that?

VA7AYG - You’re not late. Thanks for replying. I’ve verified many times and confirmed through the test done in comment 13 that the cable is in all the way.

Did you really get your windows using soundmodem to work through the Digirig to control your Yaesu VX-6R? I’m currently suspecting that soundmodem won’t work with this configuration and I need to find a different windows software packet modem to make this hardware config work.

I use digigig cable with my VX 6R using soundmodem and it works fine. Only settings on radio I change are squelch and volume.