Digirig with Winlink and UZ7HO soundmodem

I’m not able to get this to TX. It RX no issues.

I cannot locate anywhere to set the TX RTS in the soundmodem software.

Anyone have this setup and working with packet Winlink?

Thanks

1 Like

Yes, I just got this setup working with a Win10 laptop, a Digirig Baofeng cable and a Retevis HT (similar to UV5R). Hoping to post all my screenshots soon… In the meantime, the RTS setting is at the bottom of the “Device” settings menu. Its poorly labeled, but this worked for me:
image

1 Like

The com port is the one shown in Device Manager under Ports (Comm and LPT) as Silicon Labs, when the Digirig is running.

1 Like

Thanks.

I see that as well, but not sure what box to check, and the advanced settings are grey’d out

1 Like

There are no boxes that need to be checked and no access to advanced options is required.
If you don’t get the PTT with the settings in acw18’s picture, try testing PTT using this method:

1 Like

The radio keys up when using the PTT A and B test in the software. I also have it PTT ing now, but it won’t release until I hit cancel on the session window.
I’m also getting a ‘unable to open com xx when initiating a session until I unplug the USB cable and plug it back in.

Thanks

1 Like

Sounds like a case of RFI. Please check “sticky PTT” section in the troubleshooting guide.

1 Like

I did take that into consideration.

I’ll try again.

Thank you

1 Like

You can confirm this by trying the same with the minimum TX power and into the dummy load.

1 Like

I’ve given up for now.

I have done everything I can think of to make this work. I’ve changed every setting in the soundmodem, tried several different baud rates, gon back to default settings, added ferrite beads to all cables, changed output power to 1 watt, used a dummy load, changed settings in Winlink, and no joy.

Back to the Mobilinkd for now.

Here is an “Almost Everything in One Place” checklist for setting up Digirig with Winlink, Soundmodem and a Baofeng UV5r-style HT. This setup works for me.
Instructions - Win10 computer - Winlink Express - Digirig - HT.pdf (183.2 KB)

1 Like

Thanks, I’ll take a look.

I just had the same problem, and I solved it by selecting TCP in the Serial Port drop down box in the Winlink Express Packet Settings window. Apparently I had selected COM10 as that is what my Digirig is set to, but of course UZ7HO could not open the com port because Winlink Express had it opened already.

73
KD5YOU

1 Like